'99 dies at idle - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 Old 05-30-2008, 12:35 PM Thread Starter
Flight Cadet
 
Join Date: May 2008
Posts: 16
'99 dies at idle

My '99 just started this last night. Runs fine at speed, but when you roll off the throttle at a light, she gets down to about 1k RPM, sputters and dies. I have to give her about 1/2 throttle to get her to re-start and keep blipping the throttle to keep her above 1k RPM or she craps out. Ran great all day. Seemed to begin after the engine got warm. I'm eager to hear some sage advice. All hoses, fuel tank venting, simple troubleshooting that I can find looks to be OK. My bike is an ex-Kalifornia unit, so I think I'll start with pulling that emissions stuff off. Then blow out the carb. What else!?!

Take care,

Waldo1
Waldo1 is offline  
Sponsored Links
Advertisement
 
post #2 of 24 Old 05-30-2008, 01:56 PM
Flight Officer
 
double a's Avatar
 
Join Date: Nov 2007
Location: Brodhead, WI
Posts: 77
What is your idle speed when warmed up? Also how old is the spark plug? Did it happen when the tank was at a low level?

98 KLR
KLX 140 (sold)
01 1150GS
2007 DR200
1988 Honda Hawk GT
double a is offline  
post #3 of 24 Old 05-30-2008, 02:08 PM
Colonel
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
I think the first thing i would try is to drain the tank, put a gallon of gas in there, add a half can of Seafoam and run that out, then do another gallon and rest of Seafoam. It almost sounds like you might have some dirt or something in the carb...It sounds like the idle mixture circuit is the culprit, in that when you let off the throttle the needle will lower back into the Main cutting off that supply and the idle mixture needle takes over. Has your bike had the OEM idle mixture plug removed under the carb? If not, you might want to remove it and open your mixture screw 2 1/2 turns from a soft seat.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote
DXKLR is offline  
post #4 of 24 Old 05-30-2008, 02:10 PM Thread Starter
Flight Cadet
 
Join Date: May 2008
Posts: 16
Idle speed when warm has generally been right around 1k. The tank had been about 1/3 full and I had topped it off about 1 day prior. Had ridden about 55 miles on that tank before this happened.

Take care,

Waldo1
Waldo1 is offline  
post #5 of 24 Old 05-30-2008, 02:24 PM
Colonel
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
Bad gas??? Bring your idle speed up to about 1250-1500. Mine did not like 1k idle at all.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote
DXKLR is offline  
post #6 of 24 Old 05-30-2008, 02:32 PM Thread Starter
Flight Cadet
 
Join Date: May 2008
Posts: 16
Bring warm-idle speed up to about 1250-1500?
Waldo1 is offline  
post #7 of 24 Old 05-30-2008, 02:46 PM
Colonel
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
yes....1250 if it will hold there. That is the middle of the idle spec.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote
DXKLR is offline  
post #8 of 24 Old 05-30-2008, 09:13 PM Thread Starter
Flight Cadet
 
Join Date: May 2008
Posts: 16
DX-

I already had a half-bottle of Sea-Foam in the 4 gallons (approx) remaining in the tank. Drilled out plug and removed the Idle speed jet, drained the carb bowl and blew compressed air through the Idler-jet through the bowl. Lots of sediment! Checked the air filter and all fittings/gaskets and re-assembled. Backed-out Idler jet to 2 1/2 turns from soft-seat and fired her up. Perfect!! Let her warm up, readjusted the idle screw to about 1300 RPM at warm adle and rode the P!$$ out of her for about 10 miles in town- perfect at all lights and stop signs. Idle never varied and nary a problem. Thanks, guys!!

Take care,

Waldo1
Waldo1 is offline  
post #9 of 24 Old 05-30-2008, 09:51 PM
Colonel
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
don't that just make ya heart pitter patter, nothing like a fine running KLR, I am glad to hear she is purring like a kitten again.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote
DXKLR is offline  
post #10 of 24 Old 08-10-2009, 09:25 PM
Recruit
 
Join Date: Jul 2007
Posts: 2
I have the same problem mine is 07 and it just died on the highway and had to walk it

I have the same problem mine is 07 and it just died on the highway and had to walk it 6 miles back to my dads. I still have no Idea of what it could be. I will be cleaning out the carb, exhaust, and doing the seafoam thing as well hopefully this will fix it. I origanally thought sparkplug and bought a knew one put it in ran fine till it got warm / hot then died and wouldn't restart untill it was cold.




Quote:
Originally Posted by DXKLR View Post
I think the first thing i would try is to drain the tank, put a gallon of gas in there, add a half can of Seafoam and run that out, then do another gallon and rest of Seafoam. It almost sounds like you might have some dirt or something in the carb...It sounds like the idle mixture circuit is the culprit, in that when you let off the throttle the needle will lower back into the Main cutting off that supply and the idle mixture needle takes over. Has your bike had the OEM idle mixture plug removed under the carb? If not, you might want to remove it and open your mixture screw 2 1/2 turns from a soft seat.
jjfreas is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
KLR 650 Knocking at Idle to 3100 rpm deacon 1987 to 2007 Wrenching & Mods 14 10-19-2014 02:06 PM
idle screw Brettrowland 2008+ KLR650 Wrenching & Mod Questions 22 03-28-2014 10:18 PM
Won't idle, floods and dies. makeer 1987 to 2007 Wrenching & Mods 6 06-28-2008 07:50 AM
Dropped it and now it dies... Help! briant3113 KLR & Other Motorcycle Related Discussion 7 06-21-2008 09:23 PM
idles but dies when gas applied bakada 1987 to 2007 Wrenching & Mods 11 05-26-2008 06:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome