Engine Temp - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-10-2008, 01:10 PM Thread Starter
Join Date: Aug 2008
Posts: 7
Engine Temp

I rode my 08 for the first time this weekend. Put on 90 miles.
Anyways its the first street legal bike Ive ever owned. The engine temp. gauge runs just above half way when I'm tooling around in 1st and 2nd gear, wether its in a parking lot or off road. Once I get up to speed in 3rd or above the gauge drops quickly down to cold.

Is this normal?? I figure that I am not riding correctly in the lower gears. What can I try to keep it cool in low gear? Certain rpm's?

thank you
Crapapple is offline  
Sponsored Links
post #2 of 5 Old 08-10-2008, 01:23 PM
BIGIRON's Avatar
Join Date: Nov 2007
Location: Corpus Christi, TX
Posts: 704
Just physics. Low speed and high rpm's don't let the cooling system work. Higher speeds put more air thru the radiator so the system works better -- you're turning the same rpm's as you do in lower gears but with a lot more air across the fins.

Just make sure your cooling fan is working. Sounds as if it is or you'd be maxing the gauge in your 1st and 2nd gear cruising or idling. You can hear the fan at low speed or idle when the coolant temp is hot enough to trigger the switch.

You can check it by disconnecting the switch wire (at the bottom of the radiator) and grounding it. The fan should come on. Be sure to pull the connector to disconnect it, not just the wire.
BIGIRON is offline  
post #3 of 5 Old 08-10-2008, 02:27 PM Thread Starter
Join Date: Aug 2008
Posts: 7
OK. I appreciate the help. I am just being precautious.
I changed the oil today and found a good amount of metal and blue chips, look like torque stripe or sealant I'm guessing.
Crapapple is offline  
post #4 of 5 Old 08-10-2008, 02:28 PM
DXKLR's Avatar
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
Thats pretty much normal. Mine will register just above the halfway mark when in lower gears and speed, especially if riding on gravel road taking it easy.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote
DXKLR is offline  
post #5 of 5 Old 08-10-2008, 09:21 PM
Flight Cadet
Join Date: Jul 2008
Location: Free Soil, Michigan
Posts: 26
Mine too

Stays just above the cold dash at highway speeds and about halfway up on the trails. The fan comes on just above the halfway point. I have a 2008 with 1000 miles on it. griffy
griffy is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
ENGINE NOISES SANS MOOSE ENGINE GUARD X6_Hustler 1987 to 2007 Wrenching & Mods 2 02-12-2010 02:29 AM
Engine VIN #? Northerner28 1987 to 2007 Wrenching & Mods 1 06-07-2008 09:14 AM
Noob with engine swap question....Will the KLR 650 engine fit in a KLR600? Juice_Man 1987 to 2007 Wrenching & Mods 0 04-01-2008 08:00 PM
What engine oil are u using? Gitrdun 1987 to 2007 Wrenching & Mods 29 02-25-2008 02:58 PM
engine oil derek 1987 to 2007 Wrenching & Mods 1 08-21-2007 05:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome