03 running bad under throdle - Kawasaki KLR 650 Forum
Go Back   Kawasaki KLR 650 Forum > KLR 650 > 1987 to 2007 Wrenching & Mods

1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-28-2012, 08:29 AM
sonnytimes sonnytimes is offline
Flight Cadet
 
Join Date: Oct 2012
Location: Gilbert, SC
Posts: 22
Default 03 running bad under throdle

I bouht a 03 about a month ago. It had 13K miles. It cranks good. Idles good. Runs pretty good going down the road. When at hiway speeds and you start to twist the throdle to increase speeds or to pass, it starts to blubber and starts bucking. If you back off and give little gas gingerly it will pick up speed. From a standstill, ope. It up and run thru the gears it does pretty good. I have run two cans of seafoam thru it with no change. I have a pitcock diaphram coming tuesday. I have verified the tank vent and is clear. The spark plug has the light brown tint so I think it is a gas issue. Any ideas? I have been searching on the forum and running out of ideas. When I take off the carb to clean it what jet sizes should be there if it is stock?

Thank you in advance for your help.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-28-2012, 09:31 AM
willys's Avatar
willys willys is offline
Colonel
 
Join Date: Oct 2006
Location: Pefferlaw,Ontario
Posts: 1,476
Default

The main jet should be a 148 but I run a 145 the pilot jet if I recall correctly is a 40, but I could be wrong.....I haven't ever changed that yet on my bike.....I see no need to. To each their own on that....

IMHO....you need to take the carb off the bike and do a complete tear down and clean it extremely well. I use Pinesol, yes the household cleaner....It works extremely well. I tear the whole carb down to nothing, let it soak in the Pinesol for 24 hours with a little shake somewhere in there to jossle up the solution as it will gel a bit if the carb is extremely dirty. I do not put the rubber or the slider in the solution !! But everything else. I then wash the entire carb with hot water to get the Pinesol out, then hit each and every air/fuel passage with carb spray making darn sure that each passage is clear and I do this both ways on each passage. Then I hit it with a last shot of compressed air from my compressor to make sure everything is out of each passage, water, carb spray or Pinesol. I do this to all jets, emulsion tubes to make sure they are all clear of any obstructions. Now it's time to rebuild the carb....simple puzzle and slap it back on the bike.
Oh I forgot, if the pilot jet screw isn't unplugged it will need to be. You will need to use a small drill bit to puncture the plug to be able to pry it out of the tube it's pressed into. Once it's out you can unscrew the pilot jet screw. I always screw it in to count the turns just for my interest.....no two carbs are the same I have found......most are close but some are stupidily lean. The best place to start final tuning is 2 turns out from gently seated. Make sure you unplug the pilot screw before soaking the carb.....sorry....
The rest is sort of like a puzzle it all goes back the way it came apart......
Check the float valve to make sure it doesn't have a groove in the rubber, if it does it's a good time to replace it. The Diaphram needs to be intact, no holes, tears or when you put it back in place, it's too stretched and is almost impossible to get to seat into it's groove. If it is too stretched then it too is a good time to replace it. Go to a Hradley dealer and buy one of their CV carb diaphrams, they are cheaper than the Kawi dealer. There is a trick to getting the diaphram to sit inside it's groove and that is to use vaseline to hold it in....not too much or the inside of your carb will get gummed up with vaseline over a period of time. Just enough to hold the rubber in the slot.

Set the idle at 1100 when it's all on the bike and running.....job done.

I would also ask for you to check if there is any cracks or leaks in the rubber intake boot between the carb and the head. When you have the carb off take the intake tube off the bike and check the rubber "O" ring to make sure it's not damaged. Also, what air filter are you running? Most will say the UNI is best, because it is. It flows the best, then a stock then a K/N strangely enough. So, buy a UNI if you want and oil it correctly.......



Hope this helps.....
__________________
Willys
Reply With Quote
  #3  
Old 10-28-2012, 02:06 PM
sonnytimes sonnytimes is offline
Flight Cadet
 
Join Date: Oct 2012
Location: Gilbert, SC
Posts: 22
Default

Took carb off and cleaned all parts. Only thing noticable was some wear on the slide. No buildup or clogs that I could find. Put back together and no improvement. If at 55 to 60 and roll on the throddle it just blobbers. If I down shift and twist it does allot better but still has some blubbering.
Reply With Quote
  #4  
Old 01-19-2013, 07:33 PM
sonnytimes sonnytimes is offline
Flight Cadet
 
Join Date: Oct 2012
Location: Gilbert, SC
Posts: 22
Default

update....... The final culprit was the air intake was partly closed off. The previous owner reinstalled it improper. Arg!!
Reply With Quote
  #5  
Old 01-19-2013, 07:53 PM
Lockjaw's Avatar
Lockjaw Lockjaw is offline
Threadjacker
 
Join Date: Jul 2008
Location: Benicia, CA
Posts: 6,447
Default

Curses. But now you got it, brother. And you know your carb doesn't have smurfs in it.
__________________
"In a car you're always in a compartment, and because you're used to it you don't realize that through that car window everything you see is just more TV." R. Pirsig

PPMC #1.
Soon, we ride.

AKA JD Mader or you can call me "Dan" just not early for dinner.

Click my handle for a link to my homepage/blog...which has nothing to do with MCs. Free literature and music! Viva La Revolucion!
-------------------
2008 KLR 650
RIP DM - Soon, we ride.
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Two running questions. 09 klr theXoomfarr 2008+ KLR650 Wrenching & Mod Questions 13 04-23-2012 02:35 PM
Help get my bike running EasyRider84 1987 to 2007 Wrenching & Mods 24 04-06-2011 12:11 AM
97 Running Hot AZ/CO-KLR650 1987 to 2007 Wrenching & Mods 2 07-18-2010 02:22 PM
running hot AZ/CO-KLR650 1987 to 2007 Wrenching & Mods 4 07-18-2010 01:35 AM
Running log of my MPG Tifford KLR & Other Motorcycle Related Discussion 4 06-02-2009 11:55 PM


All times are GMT -5. The time now is 02:55 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum