Coil Question - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-02-2007, 12:04 PM Thread Starter
 
Join Date: Jul 2007
Posts: 8
Coil Question

I own a 1987 KLR650 that sat for 5 years, after a carb cleaning, a new gas tank, and a side stand switck bypass I finally got it running. However, it runs when I get off work and in the morning when I get on it to drive it to work it won't start. Can the coil have an intermintent problem, or do the go totally out when the go bad? It turns over good but will not fire.
blprince is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-05-2007, 03:24 AM
Lifetime Member
 
Daddyjoe's Avatar
 
Join Date: Sep 2006
Location: Riding around the USofA
Posts: 1,429
I have seen coils on cars work sometimes, and not work sometimes. I guess a coil iss a coil and they would/could be the same as the one on that car.

How do you get it started at work? Have you bypassed the clutch safty switch? How do you get it started to get it to work?

Today is the first day of the rest of your life.
Daddyjoe is offline  
post #3 of 5 Old 08-05-2007, 06:35 AM Thread Starter
 
Join Date: Jul 2007
Posts: 8
There is nothin special that I do to get it started in the evenings, it just starts. I turn the choke on and hit the start button and it starts. In the morning when I want to ride it to work I do the same thing and it acts like it isnt getting any fire
blprince is offline  
 
post #4 of 5 Old 08-05-2007, 06:40 AM
Lifetime Member
 
Daddyjoe's Avatar
 
Join Date: Sep 2006
Location: Riding around the USofA
Posts: 1,429
It sounds a lot like the clutch safty switch, and I would check the sidestand bypass to ensure it isn't loose.

Today is the first day of the rest of your life.
Daddyjoe is offline  
post #5 of 5 Old 08-05-2007, 03:06 PM Thread Starter
 
Join Date: Jul 2007
Posts: 8
If the clutch safety switch wasnt working, the motorcycle wouldnt even turn over. It turns over very well, it just seems to not be firing. I guess I'll take it apart and check fire again, the wires are still twistes together on my side stand bypass so I dont think thats it either
blprince is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Members.. Ask a question.. Any question.. Paper The Off Topic Lounge 85 05-23-2012 11:43 AM
Just a question. 2006klr650 Southeast Riders 15 09-03-2008 03:04 PM
PCV mod question thumbs 1987 to 2007 Wrenching & Mods 1 08-31-2008 08:10 PM
another oil question Kawi_KLR650 2008+ KLR650 Wrenching & Mod Questions 28 07-14-2008 05:03 PM
KLX Question double a 1987 to 2007 Wrenching & Mods 2 05-28-2008 01:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome