battery is good yet bike won't start or light up. - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 10-15-2007, 08:57 PM Thread Starter
1st Gear
 
Join Date: Oct 2007
Posts: 20
battery is good yet bike won't start or light up.

I took apart the ignition last week to get a new key and got the new key and rode the bike about 100 miles with no problems. Today I rode the bike about ten miles and when I shut it off it was dead. I noticed when I was riding the bike that the Tah was jumping around like it was cutting off and on. I unfastened two of the bigger plug in connetions that are just under the fairing when I took out the ignition. I thought I got them back together tight but one of those might have rattled loose. I am also wondering if the ignition switch didn't get put back together just right and it is not making contact. Any other ideas. I am going to work on it tomorrow.
chopper72 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-15-2007, 09:10 PM
5th Gear
 
Join Date: Sep 2006
Posts: 4,700
Sounds like you've got a loose ground connection.
Check everything you worked on, but also check your battery connections.

Now, by not "lighting up" do you mean that no lights (even indicator or panel lights) are coming on when you turn the key on?

Anyway, go through what you've already done and check for good connections. If I were you, I'd spend $3 for a test light to see where you have ground and where you don't.

Good luck, and let us know what you've found!!
Paper is offline  
post #3 of 6 Old 10-15-2007, 09:19 PM
4th Gear
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
Check the connector plug under the seat where the fuses are above the battery, mine did that exact same thing last week and that plug even tho it looked connceted had worked loose. I had no light, horn, or starter, or panel lights.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote

Last edited by DXKLR; 10-15-2007 at 10:24 PM.
DXKLR is offline  
 
post #4 of 6 Old 10-15-2007, 10:06 PM Thread Starter
1st Gear
 
Join Date: Oct 2007
Posts: 20
yeah no lights whatsoever

No panel lights etc. Remember the bike ran fine until I turned it off.
chopper72 is offline  
post #5 of 6 Old 10-16-2007, 02:12 PM Thread Starter
1st Gear
 
Join Date: Oct 2007
Posts: 20
Thanks for the help. It was the fuse box. The conection was good but a 25 amp fuse was blown. I also noticed that the right front blinker doesn't work but it worked yesterday. Can a light bulb blowing out kill a fuse?
chopper72 is offline  
post #6 of 6 Old 10-16-2007, 05:56 PM
4th Gear
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
I wouldn't think so, but might depend on if you have a short. I changed all my fuses over to Circuit breakers. very easy to do and you never have to worry about having to change a fuse again. The upside to this is, if you trip a breaker, all you do is turn the key off to reset the breaker. If it keeps tripping then you have a problem you need to address. Sure beats having to pull the seat off late at night and locate the old archaic style fuse to fix the blown one with.

Check out this site on how to do it.
http://www.geocities.com/MotorCity/D...4/page122.html

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote

Last edited by DXKLR; 10-16-2007 at 05:58 PM.
DXKLR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
bike wont start TEXAS 650 1987 to 2007 Wrenching & Mods 20 05-18-2008 06:09 PM
Bike won't start in gear no matter what I do. Timbo KLR & Other Motorcycle Related Discussion 22 01-02-2008 07:50 AM
Bike wont start blprince 1987 to 2007 Wrenching & Mods 6 07-25-2007 07:19 AM
How to start bike in gear robsong 1987 to 2007 Wrenching & Mods 2 07-08-2007 09:19 AM
Bike will not start in gear with the clutch in Richard Denham Introductions 2 04-23-2007 08:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome