Headlight and instrument panel won't light up. - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-01-2014, 09:55 PM Thread Starter
1st Gear
 
Join Date: Mar 2008
Location: Utah
Posts: 59
Send a message via MSN to Cabron
Headlight and instrument panel won't light up.

My headlight and instrument panel won't light up, though the turn signals, rear brake light, and neutral light all work. High beam light does not turn on. The problem occurred when I had just driven a short distance and was pulling into a parking space. About two days before, a friend and I had taken the bike apart to do the doohickey upgrade. No sign of problems with the lights until the night when the headlight, etc. suddenly turned off. What are my possible culprits here?
Cabron is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-01-2014, 10:14 PM
1st Gear
 
Ghostt's Avatar
 
Join Date: Nov 2014
Location: Summer Shade, Ky.
Posts: 20
Check fuses?
Ghostt is offline  
post #3 of 3 Old 12-02-2014, 12:53 AM
4th Gear
 
Join Date: Oct 2013
Location: Chilliwack, BC, Canada
Posts: 1,481
I recommend that you cut out the original fuses and splice in some better ones such as this type of weatherproof ATC fuse holders:
http://www.ebay.com/itm/Weatherproof...item43a00a2c3b

Or some of the new fangled ones. ;-)

I always extend the wires to place the holders near the Starter Relay so they can be accessed with out hauling the Tupperware party. While you're at the task, do the same for the Cooling Fan Fuse.
Normk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
07 headlight tail light problem thumbs 1987 to 2007 Wrenching & Mods 14 09-07-2014 11:57 AM
2000 klr headlight and tail light but no neutral or elec start Rmaligie 1987 to 2007 Wrenching & Mods 8 08-16-2012 07:50 AM
No headlamp, no instrument cluster illumination, no rear running light. Drake 1987 to 2007 Wrenching & Mods 3 07-23-2011 10:04 PM
battery is good yet bike won't start or light up. chopper72 1987 to 2007 Wrenching & Mods 5 10-16-2007 05:56 PM
Instrument panel illumination question Kawioops 1987 to 2007 Wrenching & Mods 14 12-08-2006 11:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome