Strange Happenings with Ignition Switch ? - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools
Old 05-11-2008, 12:39 AM Thread Starter
1st Gear
 
Join Date: Apr 2008
Location: Joplin, MO.
Posts: 17
Strange Happenings with Ignition Switch ?

I got an 01 KLR with 23,000 Miles 3 weeks ago, lots of fun ! However, a strange thing happened on the way home with it the day I got it. I turned off the bike with the with the ignition switch and when I got ready to continue riding, I switched the bike on with the key hit the start button and nothing happened? I played with the key, turned it a bit harder to the right and hit the start button and it fired right up. During the past three weeks, I have ridden the bike about 500 Miles with no problems except for today. I was riding, stopped on the side of the road to rest - got ready to go - hit the start button and nothing. I did notice the headlight, blinkers, and horn all worked when I turned on the ignition, but nothing happened when I hit the start button. So I pulled the seat, checked the fuses - all good. Tried to start again - nothing, but I did notice the green neutral light would not come on. So I fiddled with the wires, speedo cluster, turned on the key on and off, and let the bike sit a bit. Then I turned on the key and noticed the neutral light was working, when to hit the start button and it fired right up. I drove the bike home made about five stops and the bike gave me no problems at all. I'm confused, Has anyone run into a problem like this before? Any suggestions would be welcomed!

DUGKLR

03 HD FLHT
02 BUELL BLAST
01 KLR650
95 HONDA CB1000
dugklr is offline  
Sponsored Links
Advertisement
 
Old 05-11-2008, 08:07 AM
 
Join Date: Apr 2008
Posts: 75
Check the neutral wire, its under the sprocket cover...

Might be loose or damaged? There is also the clutch safety under the left grip, that gets crud in it and can prevent you from starting.

Hope this helps.

Sean
Florida Marine is offline  
Old 05-11-2008, 10:15 AM
4th Gear
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
One other thing to check that happens with my 07 some. There is a main wire connection under the seat where your fuses are located on top of the battery. That male/female connection will work loose sometimes, and even tho it looks connected, i have to move mine around so that it will work. Sometimes, I have hit the starter and then nothing, then to have it start right up the next time. It took me a couple of weeks of searching to finally figure out what was going on. Now everytime that happens I push the plug together and she will start with no problem. Of course, all of this is considering you have done all the safety bypass mods. If not, you may need to look into the kickstand safety switch and the clutch safety switch and if they haven't been bypassed, i would suggest doing that.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote
DXKLR is offline  
 
Old 05-12-2008, 12:37 AM Thread Starter
1st Gear
 
Join Date: Apr 2008
Location: Joplin, MO.
Posts: 17
Thanks Gentlemen. I did check all the connections under the seat, and all looked good. I hope to do the bypass next weekend, if time permits. I did ride the KLR today with no problems. Last Night just about 10 miles south of me here in Newton County, MO. and In Ottowa County, OK. We had a very destructive EF4 tornado. 22 People were killed, and hundreds lost there homes. I was able to ride the KLR into the damage sights today and check on my friends. One buddy and his wife took shelter in their bathroom shower and only the four walls of their bathroom was all that was left of their home. They are so lucky to be alive! I could not have reached them without the KLR, I'm glad it ran OK! I had to ride through pastures & ditches to get around down trees and power lines. My daughter had a high school classmate that lost her Dad, Mom, Brother, and Grandmother. They were traveling in their car and picked up by the tornado. Please keep these folks in your thoughts and prayers!
dugklr is offline  
Old 05-29-2008, 10:53 PM Thread Starter
1st Gear
 
Join Date: Apr 2008
Location: Joplin, MO.
Posts: 17
500 More Miles And No More Ignition Or Starting Problems, But I Did The Clutch Bypass Today. Thank You, It Worked! I Stalled The Bike Going In A Tunnel With Running Water & It Was Sure Nice Just To Pulling In The Clutch & Hit The Start Button! I Kept My Feet Nice & Dry.

However, The Neutral Light Stays On In Neutal, Goes Off When In First Just Like It Should. But In Second & Up The Neutral Light Stays On & Goes Out Only When I Pull The Clutch In To Shift. I Guess I Buttoned Something Up Wrong. I Jumped The Two Striped Wires And Pluged The Connector Back Together. Perhaps I Should Have Just Left The Connector Unplugged? I Might Try To Pull The Cover Back Off And Unplug The Connector To See What Happens.

I Left The Kickstand Switch Hooked Up, I Have A 16 Year Old Son That Rides Sometimes And I Thought It Might Be A Good Idea To Leave That One Alone For Now.

Dugklr

03 Hd Flth
02 Buell Blast
01 Klr650
95 Cb1000
dugklr is offline  
Old 05-29-2008, 11:39 PM
4th Gear
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
You did correct on the plug, it should stay plugged up. I'll have to give the neutral light some thought.

Good idea on the kickstand switch, can't blame you for that. I am glad she is running good now for you.

Check the wire down by the small sprocket, make sure it is connected correctly to the electrical post. I think that is the neutral switch wire. Might trace it upwards and make sure it isn't grounding somewhere.

Here is a link for the wiring diagram.
http://www.bigcee.com/faq/KLR650-col...ng-diagram.jpg
It shows that the neutral switch also is in conjunction with the starter lockout switch. You might have a problem there.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote
DXKLR is offline  
Old 05-30-2008, 01:56 AM Thread Starter
1st Gear
 
Join Date: Apr 2008
Location: Joplin, MO.
Posts: 17
Ok. I Pulled The Sprocket Cover Off And Clean Out The Awful Greasy Mess And Check The Neutral Wire. It Was Fine. So Then I Unpluged The Connector Under The Speedo Shroud, And Perfection! Neutral Light Only Came On Only When In Neutral And The Bike Starts In Gear. It Might Have Something To Do With My Ozark Hillbilly Way Of Doing Things. What I Did Was Unplug The Connector. Then On The Female Side Of The Connector I Ran A Small Copper Wire About 4 Inches Long Underneath The Plastic Entry Point Of Each Stripped Wire Into The Connector Until It Reached Each Metal Terminal To Connect The Circut. I Taped & Sealed It Up And Shazam It Worked.

Dugklr

03 Hd Flht
02 Buell Blast
01 Klr650
95 Cb1000
dugklr is offline  
Old 05-30-2008, 06:09 AM
4th Gear
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
Excellent. Yep sometimes those pesky electrical problems make ya scratch ya head and say WTH!! LOL... Glad you got it fixed.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote
DXKLR is offline  
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Sounds hugegladiator 2008+ KLR650 Wrenching & Mod Questions 22 07-16-2008 11:46 PM
Ignition problem?? derek 1987 to 2007 Wrenching & Mods 2 12-13-2007 08:57 PM
ignition coachz 1987 to 2007 Wrenching & Mods 3 11-27-2007 12:46 PM
Saftey Switch by-pass SWITCH Daddyjoe How To's & Tech Guides 4 07-12-2007 08:07 AM
Ignition Bypass Peter Murphy KLR & Other Motorcycle Related Discussion 3 06-30-2007 08:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome