odometer question - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 07-14-2008, 10:03 AM Thread Starter
2nd Gear
 
Join Date: Mar 2008
Location: Souderton, Pa
Posts: 211
odometer question

I only have about 1k on my 07 but I noticed the trip odometer sometimes moves a head of it self. For example I may have 215 miles on the trip odometer and it may read half way between 2 and 3 and 1 and 2 but the last didiget usualy is ok. It has done this twice between fill ups. Is there a quick fix for this, is it normal or is it time to take it back and have them mess with it?

thanks

Gary
Souderton, Pa.
89 xt350 wish I still had her
05 Suzuki DRZ 400
92 K75s
07 KLR 650
13 Triumph Storm
thumbs is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-14-2008, 10:12 AM
3rd Gear
 
BIGIRON's Avatar
 
Join Date: Nov 2007
Location: Corpus Christi, TX
Posts: 704
Not sure I really understand, but the odo numbers roll into place instead of "snap" into place. At least most I've seen.

Like the "single mile - 0 to 9 - will probably start to roll to the next number when the tenths indicator hits .7 or .8. Or something like that.
BIGIRON is offline  
post #3 of 5 Old 07-14-2008, 11:43 AM Thread Starter
2nd Gear
 
Join Date: Mar 2008
Location: Souderton, Pa
Posts: 211
I think it rolls into place but the problem is it goes past the number half way to the next one. If I don't pay attention to the milage I could read it as the number either before or after where it should be. For example if it is supposed to read 200 miles it may read between 2 and 3 and 0 and 1. Now I can probably figure the hundreds but the tens you could read either way and really not know it.

Gary
Souderton, Pa.
89 xt350 wish I still had her
05 Suzuki DRZ 400
92 K75s
07 KLR 650
13 Triumph Storm
thumbs is offline  
 
post #4 of 5 Old 07-14-2008, 02:18 PM
4th Gear
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
That sounds like an alignment problem with the internal gears. If its under warranty, let the dealer replace it.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote
DXKLR is offline  
post #5 of 5 Old 07-14-2008, 02:22 PM Thread Starter
2nd Gear
 
Join Date: Mar 2008
Location: Souderton, Pa
Posts: 211
Yeah that's kinda what I thought but didn't know if ya had to turn it a few times when you reset the thing. It's under warrenty so I'll take it back and hope they don't screw something else up. LOL

thanks

Gary
Souderton, Pa.
89 xt350 wish I still had her
05 Suzuki DRZ 400
92 K75s
07 KLR 650
13 Triumph Storm
thumbs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Members.. Ask a question.. Any question.. Paper The Off Topic Lounge 85 05-23-2012 11:43 AM
Just a question. 2006klr650 Southeast Riders 15 09-03-2008 03:04 PM
PCV mod question thumbs 1987 to 2007 Wrenching & Mods 1 08-31-2008 08:10 PM
another oil question Kawi_KLR650 2008+ KLR650 Wrenching & Mod Questions 28 07-14-2008 05:03 PM
KLX Question double a 1987 to 2007 Wrenching & Mods 2 05-28-2008 01:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome