won't start - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 07-20-2008, 11:35 AM Thread Starter
2nd Gear
 
Join Date: May 2008
Posts: 153
won't start

Bike won't start. Took my first long ride yesterday (about 6 hours) and went to the garage to take a quick ride, and it won't starter sounds like the start is strugglin like it's not gettin enough juice...I'm thinkin it's a weak battery....any ideas? Should I go get a new battery?
Rick

Last edited by rickyp3278; 07-20-2008 at 11:38 AM.
rickyp3278 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-20-2008, 11:39 AM
1st Gear
 
Join Date: May 2008
Location: Michigan
Posts: 47
check the batt. water level? Did you try charging the battery? I would start with battery mait. first.
Northman is offline  
post #3 of 7 Old 07-20-2008, 12:09 PM
4th Gear
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
Definately sounds like a weak battery. I suggest tossing the factory unit for a good non maintenance one.

2008 DL650 VStrom Yellow and Black
Previous ride was a 2007 KLR Black/Silver, I miss it..
Looking to get back into KLR's sometime soon.

Best Auto/Moto Insurance | Motorcycle Protection Today | FREE Trade-In Quote
DXKLR is offline  
 
post #4 of 7 Old 07-20-2008, 12:16 PM
3rd Gear
 
BIGIRON's Avatar
 
Join Date: Nov 2007
Location: Corpus Christi, TX
Posts: 704
You can get cheaper online, but I just got an ORiellys AGM for $83 out the door w/tax and recycle fee. 1 year no prorata replacement. I was OK to pay the extra cause I needed it right now and if necessary I can replace it around the corner instead of having to ship.
BIGIRON is offline  
post #5 of 7 Old 07-20-2008, 05:36 PM Thread Starter
2nd Gear
 
Join Date: May 2008
Posts: 153
got my hands on a battery charger, hooked it up, and the bike fired fight up like it was gonna jump out of its plastic. Looks like I'm headed to batteries plus for a new battery tomorrow. When it was just starting to fire up, it let out a nasty backfire. Hasn't done that b4. Anyone had that happen...should I worry?
Rick
rickyp3278 is offline  
post #6 of 7 Old 07-20-2008, 06:19 PM
3rd Gear
 
BIGIRON's Avatar
 
Join Date: Nov 2007
Location: Corpus Christi, TX
Posts: 704
Probably just residual fuel in the system from earlier cranking efforts. No problem - just clearing her throat.

Suggest spend the extra $$ for the AGM / maintenence free battery. It'll pay in the long run. I think Wanderer has one from BatteryPlus.
BIGIRON is offline  
post #7 of 7 Old 07-20-2008, 11:06 PM Thread Starter
2nd Gear
 
Join Date: May 2008
Posts: 153
will do. There are 2 things you don't go cheap on....tires, and batteries. Thanks for the battery advice fellas.
Rick
rickyp3278 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wet - Will not start Florida Marine KLR & Other Motorcycle Related Discussion 16 01-12-2017 09:54 AM
bike wont start TEXAS 650 1987 to 2007 Wrenching & Mods 20 05-18-2008 06:09 PM
OK I'll start it Mark B (4) You've been spotted 5 05-09-2007 05:07 PM
KLR NO START! bill stanley 1987 to 2007 Wrenching & Mods 3 01-07-2007 03:26 PM
Gunny is here, you can start now LOL gunny Introductions 7 10-06-2006 02:57 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome