starting puzzle - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-18-2009, 03:38 PM Thread Starter
 
Join Date: Mar 2009
Posts: 1
starting puzzle

I have a '01 KLR650. Last summer I started having problems getting it to run after I started it. Meaning: I ccould start it but it would have to idle for at least 5 minutes to warm up so I could actually drive it. Seemed I was having issues with the vacuum line from the petcock to the carb. I replaced it which seemed to fix it for awhile but thenI continued to have problems, eventually it even gave me fits out on a mountain trip. In any case, I gave up on that and recently replaced the petcock with a pingle that doesn't have a vacuum line. Now it is even more tempermental to run after start. I can start it easily enough, but until I can get it to idle without the choke, it will die if I try to give it any gas with the throttle. Tho' I had the tank off all winter, I tried some seafoam, but it doesn't seem to have made a difference. Nothing else has changed from last year when it was running fine.

Then as I was testing it with runs down to the mailbox, I started to hear a noise. At first I thought it sounded like the speedometer cable, but then it was louder. Sounds like metal on metal, like a chain or something. It isn't constant and Seems to appear upon deceleration. That is making me really nervous. I don't know if these two issues are related, but thought I should mention it. I replaced the doohickey myself a couple years ago, but that is about as complicated a job I would want to do with a m/c. I'm not incompetent but also don't consider myself a master bike mechanic. Any ideas or suggestions you all have would be appreciated.
---wha--- is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
cold weather starting shadow 2008+ KLR650 Wrenching & Mod Questions 24 11-16-2010 08:38 AM
Very hard starting when cold pwoolford 1987 to 2007 Wrenching & Mods 0 05-20-2008 09:26 AM
Starting out (Nebraska) PsychoRookie Introductions 5 05-28-2007 09:04 AM
Starting maint. for TDA (tour de fl) Daddyjoe 1987 to 2007 Wrenching & Mods 0 01-02-2007 06:57 PM
Moderator Search Starting klr650 Forum News, Suggestions & Help 17 10-05-2006 09:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome