New KLR Rider No spark problem - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-17-2017, 08:58 PM Thread Starter
Neutral
 
DimosGR's Avatar
 
Join Date: Apr 2017
Location: Northern Greece
Posts: 1
New KLR Rider No spark problem

Greetings Riders ,
I have been spending alot of hours trying to get my KLR running and some help from more experienced riders would be , hopefully , a puzzle solver in this one.
First of all my bike is a KLR 650 Tengai 1991 (Gen 1)
I had a no spark problem so i decided to buy another klr for spares since it was a good price. Owner said he bought it at 2005 the bike looked like an 00' but it sparked and this was all i wanted.
After replacing my CDI , Coil , R/R and stator with the "00's" ones i still got no spark.
Decided to test the wiring harness on mine , so i connected only the necessary and got a spark so i got to the decision of ditching my wiring harness for the other one.
Once i finished installing the harness... No spark yet again.
Called in a friend with a multimeter and measured the voltage on the Black and Black/Yellow wire connected on the coil , we got around 20 pulsing volts.
We both thought the coil was fried so we tested again with another coil , still no spark.
We then tested the coil on another bike which surprisingly started at once.
What could be the problem? Do you guys have something to suggest.. I am really feeling lost in this one after spending around 12 hours connecting/disconnecting things and searching for bad grounds or connections.

Thank you in advance!!

Last edited by DimosGR; 04-17-2017 at 09:12 PM.
DimosGR is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-27-2017, 10:16 AM
Neutral
 
Join Date: Apr 2017
Posts: 3
might seem rudimentary, but bypass your safety switches, kickstand, etc.
spinyard is offline  
post #3 of 3 Old 04-28-2017, 04:17 AM
5th Gear
 
Join Date: Jan 2011
Posts: 4,228
Pickup coil and wiring? Wiring is close to countershaft sprocket; snags/breaks/intermittent connection possible . . .
Damocles is offline  
Sponsored Links
Advertisement
 
Reply

Tags
cdi, coil, spark, stator, wiring

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Klr 600 No Spark :-( larslykkegaard Other KLR's - 250, 600, Tengai, C Models, KLX... 2 06-10-2016 08:35 PM
new owner of 09 with spark problem 78whiteorbs 2008+ KLR650 Wrenching & Mod Questions 5 08-13-2015 11:10 PM
New to the KLR world, and issue with spark already :( twofastfouryou350 1987 to 2007 Wrenching & Mods 8 05-18-2010 07:36 PM
Cold starting problem- no spark. HELP! Hayduke 1987 to 2007 Wrenching & Mods 9 01-02-2007 03:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome