help pls. bad idle - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 Old 04-16-2009, 12:55 AM Thread Starter
2nd Gear
 
Join Date: May 2008
Location: Nanaimo, BC, CANADA
Posts: 269
help pls. bad idle

Hey all. been a while for me posting. looking for some help with a idle issue. 2002 with 12000km. Jardine exhaust and K&N, petcock mod. never adjusted or jetted the carb. ran great last fall. stored with tank empty and carb drained. does not get cold here just a little below 0 c in the winter.
so ... bike starts great, but when the choke is reduced after a minute of warming up or so the idle is great for 10-20 seconds then drops about 500 rpm and cycle repeats. frequently enough to stall (espically annoying at stop lights.) runs great at RPM. still great power with the jardine. no backfiring or surging that i can tell. idle had always been good at ~1000.
new fuel - no change
tank lid open - no change
methylhydrate - no change
removed air filter - dirty but no change
cleaned plug- moderate fouling but no change
pulled carb. float bowl had a bit of grunge. float is free, gaskets good, diaphragm good. jets no obvious crap. everything blasted with carb cleaner. -no change.
oil not changed yet but level looks good and changed in november.

so wadda think? i still wonder about the jets in the carb, one flushed really well into the lower bowl, but the other not. is this just normal or could it be plugged? maybe not carb? valves, timing etc. i'm still a bit of a noob with this bike. at least i can still ride it.

thanks for any input.

Last edited by doc3toes; 04-23-2009 at 11:42 PM.
doc3toes is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old 04-16-2009, 06:13 AM
 
Join Date: Apr 2009
Posts: 6
I had a similar problem once with a Yamaha XTZ660 being ridden after a month or so storage. Like you I stripped and cleaned the carb with no impact (in fact it felt like I cleaned it 20 times trying to find some muck I thought I must have missed).

The solution was a new spark plug which was a surprise since the old one still gave a good strong spark everytime I checked it outside the engine. For some reason the old spark plug appeared to be breaking down as soon as it started to get warm. I have no explanation why it happened after a short period of storage and not before but after the change the problem never came back.

Good Luck.
Mart1williams is offline  
post #3 of 23 Old 04-16-2009, 03:31 PM Thread Starter
2nd Gear
 
Join Date: May 2008
Location: Nanaimo, BC, CANADA
Posts: 269
thanks. i will definately replace it as soon as i can get my hands on a new one. does anyone run any fancy plugs in their bikes? splitfire etc?
doc3toes is offline  
 
post #4 of 23 Old 04-17-2009, 11:38 PM Thread Starter
2nd Gear
 
Join Date: May 2008
Location: Nanaimo, BC, CANADA
Posts: 269
changed the plug to an ngk iridium. no change. added some cab cleaner to the last gallon or so of gas. going to run that through. any other thoughts? thx.
doc3toes is offline  
post #5 of 23 Old 04-18-2009, 03:44 AM
4th Gear
 
tomatocity's Avatar
 
Join Date: Sep 2006
Location: Sacramento, CA
Posts: 2,453
KLRs run lean in the stock state and you added an exhaust that makes it even more lean. Do yourself a favor and correct the caburetor to match your exhaust then work from there.

Tim

2005 KLR 685
2015 Yamaha Super Tenere ES, 5/23/2015
2012 Yamaha Super Tenere; Purchased 7/30/2011; Sold 5/23/2015
tomatocity is offline  
post #6 of 23 Old 04-18-2009, 02:19 PM Thread Starter
2nd Gear
 
Join Date: May 2008
Location: Nanaimo, BC, CANADA
Posts: 269
I was definately thinking of putting the jet kit in that i have, but then i was thinking is it better to get it running better first, or just do it? at least in this state i can still ride it, just stalls a lights (makes me look like a turd). i guess if one of the jets is plugged then changing a new one in should solve the problem. i guess the hesitation is that i dont know my way around the carb all that well. but i can always take pics and post for help i guess if i have problems. maybe tonight i'll rip into it. thx
doc3toes is offline  
post #7 of 23 Old 04-18-2009, 04:47 PM
4th Gear
 
tomatocity's Avatar
 
Join Date: Sep 2006
Location: Sacramento, CA
Posts: 2,453
If you add a little Choke and it runs better then it is running lean. I don't know what jet kit you have but none of then are difficult or take very long to install.
There might be someone in your area that is familiar with KLRs. Where do you live?

Tim

2005 KLR 685
2015 Yamaha Super Tenere ES, 5/23/2015
2012 Yamaha Super Tenere; Purchased 7/30/2011; Sold 5/23/2015
tomatocity is offline  
post #8 of 23 Old 04-19-2009, 03:52 PM Thread Starter
2nd Gear
 
Join Date: May 2008
Location: Nanaimo, BC, CANADA
Posts: 269
nope choke does not make it run better, just ups the rpm so it doesnt stall, the idle still falters. I installed the jet kit and no difference. what is next, valves? iguess i need to keep reading.
doc3toes is offline  
post #9 of 23 Old 04-20-2009, 12:53 PM
 
Join Date: Apr 2008
Posts: 19
I raised my idle, so it idles around 1,300rpm. It seemed to help.
SuRfR is offline  
post #10 of 23 Old 04-20-2009, 04:39 PM Thread Starter
2nd Gear
 
Join Date: May 2008
Location: Nanaimo, BC, CANADA
Posts: 269
i would have to keep mine at 15-1800 in order to prevent a stall. not an option. could the doohickey cause this problem? i am going to order the gear to get that done too.
doc3toes is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
KLR 650 Knocking at Idle to 3100 rpm deacon 1987 to 2007 Wrenching & Mods 14 10-19-2014 02:06 PM
Proper idle? Lockjaw KLR & Other Motorcycle Related Discussion 12 07-14-2014 08:05 PM
idle screw Brettrowland 2008+ KLR650 Wrenching & Mod Questions 22 03-28-2014 10:18 PM
'99 dies at idle Waldo1 1987 to 2007 Wrenching & Mods 23 11-05-2009 09:49 PM
Won't idle, floods and dies. makeer 1987 to 2007 Wrenching & Mods 6 06-28-2008 07:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome