KLX650 transmission problem - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 07-26-2009, 01:01 PM Thread Starter
Neutral
 
Join Date: Jul 2009
Posts: 4
KLX650 transmission problem

My son just picked up an older 93 klx650. Has only had it about 3 weeks and now it has a tranny problem.
Symptons are its stuck in gear and wont go to neutral.
The shifter will click up and down but on the up stroke it seems.... to go to far?
The clutch will disingage. Any ideas what this might be before we split the cases? I dont hear any grinding noises and any thing else out of the ordinary. No problems with it up until then.

He says he shut it off in gear and then it wouldnt go in to neutral when he tried to fire it back up. It wont push start since its in like 3 or 4th?? gear.

Any one have a source for a decent parts diagram or manual.

Thanks in advance!

Last edited by topshelf; 07-26-2009 at 01:44 PM.
topshelf is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 07-26-2009, 01:33 PM
2nd Gear
 
Join Date: Apr 2009
Location: Pennsylvania
Posts: 109
Do you have the correct oil in it? ..
I would lift it so rear wheel is off ground milk crate works but bike life much better..

and get it in neutral.. see if it will start by itself.. if not you have other issues also..

take it one step at a time.. if not sure on what oil is in it.. drain and re do it.. with only approved oil for wet clutch .. check the battery for full charge? just do all over basic maintance and see if you can find the issue..
Gunjunkie is offline  
post #3 of 8 Old 07-27-2009, 12:20 PM Thread Starter
Neutral
 
Join Date: Jul 2009
Posts: 4
Quote:
Originally Posted by Gunjunkie View Post
Do you have the correct oil in it? ..
I would lift it so rear wheel is off ground milk crate works but bike life much better..

and get it in neutral.. see if it will start by itself.. if not you have other issues also..

take it one step at a time.. if not sure on what oil is in it.. drain and re do it.. with only approved oil for wet clutch .. check the battery for full charge? just do all over basic maintance and see if you can find the issue..

IMO Its not an oil issue
Have tried to get it into neutral and thats pretty much the problem, it wont go into neutral.

The battery is fine. That shouldnt effect the the tranny as far as I know?

Appreciate the help.

Anyone ever have one do this?
topshelf is offline  
 
post #4 of 8 Old 07-27-2009, 05:13 PM
2nd Gear
 
Join Date: Apr 2009
Location: Pennsylvania
Posts: 109
Unhook the safter switch on the kickstand and see if you can start it with clutch in? ( mine will now start in gear with clutch in..)

If you can't find neutral I would say something may be broke in it ..
Gunjunkie is offline  
post #5 of 8 Old 07-27-2009, 07:11 PM
Lifetime Member
 
flash's Avatar
 
Join Date: May 2008
Location: North Texas
Posts: 1,534
Send a message via Yahoo to flash
Bent shift forks, been there, done that. Did he drop it on the left side?
flash is offline  
post #6 of 8 Old 07-28-2009, 07:57 PM Thread Starter
Neutral
 
Join Date: Jul 2009
Posts: 4
Quote:
Originally Posted by flash View Post
Bent shift forks, been there, done that. Did he drop it on the left side?

well as far as I know, no. More than likely though yes I would say he layed it down. Pretty much what I asked him also. But the shift lever looks fine, not bent up or torqued

OK so if you have fixed this one do I need to split the cases to get to the shift fork? I have never had a Kaw apart and the online diagrams I have found dont show the whole case so its tough to tell.

Any help with online diagrams or just hints would be great!
topshelf is offline  
post #7 of 8 Old 08-03-2009, 09:59 AM Thread Starter
Neutral
 
Join Date: Jul 2009
Posts: 4
Pulled the right side cover last weekend. Well the shift drum was NOT exposed so now I'm at a loss. Just for grins I ordered a repair manual online on Saturday so hopefully that will shed some more light on whats involved in fixing it.

On the upside it will at least get an oil change along with filter once it gets fixed
topshelf is offline  
post #8 of 8 Old 07-12-2013, 04:34 PM
1st Gear
 
Join Date: Aug 2012
Location: Central Illinois for now
Posts: 28
When you had the right side case off did you notice the flat spring on the lower left? If it is not there then you need to find it then replace it within a new one. This spring is the shifter change lever spring. It holds the external shift fork up to engage the linkage that changes the transmission. If it is in place & functioning correctly then your next step is to remove the clutch basket & check the linkage behind it. If that is all working correctly then you will probably have to split the cases. Good luck & let's hope it is just a weak spring.
phila1114 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd Problem with 2 up sm0kediver 1987 to 2007 Wrenching & Mods 3 10-02-2008 08:15 PM
Transmission Problem? Markk9 2008+ KLR650 Wrenching & Mod Questions 9 07-25-2008 04:32 AM
Fuel problem JesseA 1987 to 2007 Wrenching & Mods 12 07-23-2008 08:57 AM
Anyone ever have this problem? changvoll 1987 to 2007 Wrenching & Mods 4 06-10-2007 12:05 AM
Battery fit problem Slaghammer 1987 to 2007 Wrenching & Mods 7 11-15-2006 08:15 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome