No Start - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 2Likes
  • 1 Post By GoMotor
  • 1 Post By pdwestman
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 07-31-2018, 02:47 PM Thread Starter
Neutral
 
Join Date: Jul 2018
Posts: 12
No Start

Picked up a KLR off craigslist a few weeks ago in pretty rough shape, however the owner said It had run fine about a year ago and had just been sitting. I rebuilt the carb using an all balls kit and put in a new battery, spark plug and fresh gas to see if it it'll start. No luck. It seems like its getting gas from the tank as I see gas in the fuel filter. It could potentially be the air fuel screw, as I forgot to note where it was positioned I started rebuilding. Any advice as to what/how I can trouble shoot would be greatly appreciated.
Nick George is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 07-31-2018, 03:17 PM Thread Starter
Neutral
 
Join Date: Jul 2018
Posts: 12
Quote:
Originally Posted by Nick George View Post
Picked up a KLR off craigslist a few weeks ago in pretty rough shape, however the owner said It had run fine about a year ago and had just been sitting. I rebuilt the carb using an all balls kit and put in a new battery, spark plug and fresh gas to see if it it'll start. No luck. It seems like its getting gas from the tank as I see gas in the fuel filter. It could potentially be the air fuel screw, as I forgot to note where it was positioned I started rebuilding. Any advice as to what/how I can trouble shoot would be greatly appreciated.
It also seemed like someone did part of a 22 cent mod. I couldn't tell if the side hole was drilled out any wider, but there was a single washer under the needle.
Nick George is offline  
post #3 of 10 Old 07-31-2018, 04:43 PM
4th Gear
 
GoMotor's Avatar
 
Join Date: May 2014
Location: Texas
Posts: 1,204
When faced with a "WON'T START" engine that I don't know the history of, I start with the essentials - fuel/air, spark, compression all at the right time and the right mixture.

First easy test. Put a spark plug on the plug wire and against the head to check for a good hot spark spark. If not, find out why.

Second easy test. Turn the gas off and drain the carb. Shoot some starting fluid in the air intake and see if it will start on this. if not, make sure you have compression.

These are the main things that can go wrong without someone fooling with the spark timing or cam timing.
Damocles likes this.

Last edited by GoMotor; 07-31-2018 at 05:08 PM.
GoMotor is offline  
 
post #4 of 10 Old 07-31-2018, 09:21 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,257
Did You remember to hook up the vacuum hose from the top of the carb to the fuel tap? This vacuum hose opens the petcock diaphragm to flow fuel ONLY when the engine is turning over, either by starter motor or by actually running.

With NO CHOKE, and fuel valve in Reserve position, crank the starter button for 20 seconds to FILL the carb. While still cranking, pull the choke lever on! Does it start or not?
insan3guy likes this.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 84,000+ miles & counting
pdwestman is online now  
post #5 of 10 Old 07-31-2018, 11:16 PM Thread Starter
Neutral
 
Join Date: Jul 2018
Posts: 12
Quote:
Originally Posted by pdwestman View Post
Did You remember to hook up the vacuum hose from the top of the carb to the fuel tap? This vacuum hose opens the petcock diaphragm to flow fuel ONLY when the engine is turning over, either by starter motor or by actually running.

With NO CHOKE, and fuel valve in Reserve position, crank the starter button for 20 seconds to FILL the carb. While still cranking, pull the choke lever on! Does it start or not?
That worked!! Thanks so much!
Nick George is offline  
post #6 of 10 Old 07-31-2018, 11:53 PM
4th Gear
 
GoMotor's Avatar
 
Join Date: May 2014
Location: Texas
Posts: 1,204
Mr. Westman.

Besides being a genital man and a scholar, you must also be clairvoyant.
GoMotor is offline  
post #7 of 10 Old 08-01-2018, 12:34 AM
5th Gear
 
Join Date: Jan 2011
Posts: 4,191
Quote:
Originally Posted by GoMotor View Post
Mr. Westman.

Besides being a genital man and a scholar, you must also be clairvoyant.
A, "genital" man?

I've always thought so!
Damocles is online now  
post #8 of 10 Old 08-01-2018, 01:15 AM
4th Gear
 
GoMotor's Avatar
 
Join Date: May 2014
Location: Texas
Posts: 1,204
Quote:
Originally Posted by Damocles View Post
A, "genital" man?

I've always thought so!
Sorry about that. Spell check did it. It is not my fault and I wasn't even there when it happened.
GoMotor is offline  
post #9 of 10 Old 08-01-2018, 09:49 AM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,257
Quote:
Originally Posted by Nick George View Post
That worked!! Thanks so much!
Your welcome Nick. Pass it on.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 84,000+ miles & counting
pdwestman is online now  
post #10 of 10 Old 08-01-2018, 09:51 AM
4th Gear
 
Join Date: Aug 2010
Location: Kelowna, B.C.
Posts: 2,236
Quote:
Originally Posted by GoMotor View Post
Sorry about that. Spell check did it. It is not my fault and I wasn't even there when it happened.
suuuuure.......



Cheers,
Dave
DPelletier is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
bike wont start. no power Jake Mountain KLR & Other Motorcycle Related Discussion 12 04-23-2012 08:32 PM
No headlamp, no instrument cluster illumination, no rear running light. Drake 1987 to 2007 Wrenching & Mods 3 07-23-2011 10:04 PM
No No NO NO NO NO NO NO!!!!! Paper Other Bikes 20 10-31-2010 10:55 PM
Bike won't start in gear no matter what I do. Timbo KLR & Other Motorcycle Related Discussion 22 01-02-2008 07:50 AM
KLR NO START! bill stanley 1987 to 2007 Wrenching & Mods 3 01-07-2007 03:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome