Horn isn't working - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 12-09-2009, 07:47 PM Thread Starter
Neutral
 
Join Date: Oct 2009
Posts: 10
Horn isn't working

My horns are not working anymore. They just stopped one day. I hit the horn button and there is a click under the dash. What should I look for first?
greenerob is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 12-09-2009, 09:18 PM
1st Gear
 
webmost's Avatar
 
Join Date: Feb 2009
Location: Delaware
Posts: 88
How can you tell?

How can you tell? No, really. Did you remove your helmet and kill the engine and listen real close? Sounded like a gerbil with the croup. Damn thing makes such a puny poot that you may just have missed it. Motorcycle horns are typically inadequate; but this one would disgrace a tricycle.

First thing you should look for? Wolo Badboy.

Unmitigated risk aversion is the new Puritanism; complete with witch hunts, funny outfits, and humorless preachers thundering doom. The name of the Deity is changed to Safety; the name of Satan is changed to Lawyer; but the object is the same: to suck the life out of life and tell you how to live it.
webmost is offline  
post #3 of 9 Old 12-09-2009, 11:02 PM
Threadjacker
 
Lockjaw's Avatar
 
Join Date: Jul 2008
Location: Benicia, CA
Posts: 6,750
Check the wire that connects to the horn. Mine vibrated loose and it sounded like it was dying. Just needed to be connected right. I have an aftermarket horn, but same deal. The horn is underneath on the right side.




"In a car you're always in a compartment, and because you're used to it you don't realize that through that car window everything you see is just more TV." R. Pirsig

PPMC #1.
Soon, we ride.

AKA JD Mader or you can call me "Dan" just not early for dinner.

Click my handle for a link to my homepage/blog...which has nothing to do with MCs. Free literature and music! Viva La Revolucion!
-------------------
2008 KLR 650
RIP DM - Soon, we ride.
Lockjaw is offline  
 
post #4 of 9 Old 12-10-2009, 06:18 AM Thread Starter
Neutral
 
Join Date: Oct 2009
Posts: 10
Quote:
Originally Posted by webmost View Post
How can you tell? No, really. Did you remove your helmet and kill the engine and listen real close? Sounded like a gerbil with the croup. Damn thing makes such a puny poot that you may just have missed it. Motorcycle horns are typically inadequate; but this one would disgrace a tricycle.

First thing you should look for? Wolo Badboy.
No, I actually have two horns. They are the same model that is used in Chrysler cars. They literally went from louder than most trucks to nothing.
greenerob is offline  
post #5 of 9 Old 12-10-2009, 07:46 AM
1st Gear
 
webmost's Avatar
 
Join Date: Feb 2009
Location: Delaware
Posts: 88
1) Check the fuse
2) If good, whip out your multi-tester and see if you get juice to the horn
3) If not, do you have juice to the relay
4) etc

Unmitigated risk aversion is the new Puritanism; complete with witch hunts, funny outfits, and humorless preachers thundering doom. The name of the Deity is changed to Safety; the name of Satan is changed to Lawyer; but the object is the same: to suck the life out of life and tell you how to live it.
webmost is offline  
post #6 of 9 Old 12-12-2009, 12:55 AM
2nd Gear
 
MotoPhoto's Avatar
 
Join Date: Oct 2006
Location: Klamath Falls, OR
Posts: 440
Did you install a relay? If so has that been checked?
Pull your horn switch a part, make sure your contacts are clean and making good contact.

Craig
KLR 650 - A18
Triumph Sprint ST - 2008
Polaris Sports Man 300 4x4 - Wife's
Polaris Sports Man 400 HO 4x4
28 foot Travel Trailer
Not enough time to play
MotoPhoto is offline  
post #7 of 9 Old 12-12-2009, 02:38 AM
3rd Gear
 
Paulo888's Avatar
 
Join Date: Feb 2008
Location: L.A. Native
Posts: 517
Get a test light and work your way back from the horn. If you have power at the horn then your fuse and the relay or switch is okay and your horn is bad.

94 KLR,tank guards,sw motech centerstand,Doo done, african switch,mirror dampners, powerpegz, twisted throttle fuses, aluminum skidplate, Bigcee shark disc and jug holder and subframe upgrade, progrip grips,maier handguards/brushguards, avon distanzias,fmf q4 exhaust, headlight guard, handlebar risers, billet rear brake reservoir bracket and guard, dual star shifter,garmin 2820 gps, tmod,disc cover, pcv mod,corbin flat
Paulo888 is offline  
post #8 of 9 Old 12-12-2009, 07:26 PM
3rd Gear
 
Hardyreels's Avatar
 
Join Date: Dec 2008
Location: Wasilla, Alaska
Posts: 507
I don't even use my horn so I have no idea how to proceed. I find that blowing a horn only further distracts someone who is already acting incompetent so I defer from making the situation worse.

Think of it like this; someone starts to pull out in front of me, I see what's happening and even if they continue I can cope with the set up. Now I blast my horn; the person hears it, hits their brake and stops, now they are blocking the road entirely, now some options I had previously are gone.

I don't blow my horn, just me but I've seen more bad results than good to a blast from a loud horn.

Spinning / flashing LED tail light;Dished seat;Nerf Bars;Panniers and rack;Aluminum skid pan;Master cylinder guard;tall shield;Heated gel grips;Acerbis Rally Pro guards with spoilers;Superbike low front fender;Doo upgrade;16T counter sprocket; K&N filter and box mod;GPS mount;Dash with voltage meter & clock;1" raising links;T bypass mod;anti vibe bars;anti vibe mirror mounts;Euro light switch; Aluminum choke leaver;new dry cell Super battery;Mefo Expolere's;New bearings and races
Hardyreels is offline  
post #9 of 9 Old 02-17-2010, 09:42 AM
3rd Gear
 
SteelB12's Avatar
 
Join Date: Mar 2009
Location: NOVA
Posts: 562
Took my bike in for the annual inspection. Guy said he couldn't pass it because the horn sounded so anemic. Figured its just the OEM horn being itself and it sucks. SO, I went to the dealer down the road to see if they had a replacement. $50 for the OEM horn!!!! and $49 for a FIAMM. That;s just nuts. Rode around the corner to the NAPA store and got a FIAMM for $14. Didn't have any relays, so I am going to try mounting with just a fuse.

Now that I have read this thread I am going to check for a loose wire first.

EDIT: Okay, I took all sorts of crap off just to get to the horn (such a PITA to get to). It bleeped when I hit the button. I removed the horn from the mount and hit the button again and it was very loud. Put it back and tightened the nut. Anemic bleep again. WTF?? Removed it and took off the bigger washer and remounted. Now its loud like it should be.. Weird! Also, I crimped the connections as they were loose and it looked like the wires would easily come off of the horn. So now I have an extra FIAMM. At least I didn't shell out $50 for the OEM horn

Erik
2003 Bandit 1200S
2009 KLR 650

74 Honda CB360

Last edited by SteelB12; 02-17-2010 at 10:47 PM.
SteelB12 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn? Lockjaw 2008+ KLR650 Wrenching & Mod Questions 22 10-04-2010 08:07 PM
normal engine working temperature amzahsulaiman 2008+ KLR650 Wrenching & Mod Questions 7 12-09-2009 02:32 PM
Link to a report I'm working on.. larryboy Travel Log & Trip Reports 3 09-11-2007 04:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome