lights dimming - Kawasaki KLR 650 Forum
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-03-2010, 07:07 PM Thread Starter
1st Gear
 
Join Date: Jan 2010
Posts: 19
lights dimming

Hello, everyone , I am a new player at this , so bear with me,, My problem is when I start my bike (1999KLR) then turn on the lights the headlight looks good , and bright, but when I rev up th engine is gets dimmer,, once it dims it does not get more , and more dimmed, just the intial time,, any help would be appreciated,, thanks in advance Scott in Prescott,Az..
ssknightrider is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-03-2010, 07:30 PM
2nd Gear
 
DonD's Avatar
 
Join Date: Jun 2008
Location: Central AZ
Posts: 177
Hey Scott..sounds like you need to check the charging system.

I would start with the battery, water level ok? Next the cable connections to the battery, remove and shine up all 4 ends and the spot they terminate to.
Replace and snug them up good.

Still a problem?, put your volt meter accross the battery leads and note the voltage not running. 13.5v? You're good, lower not good, needs a charge. Start and note the voltage as you rev up the engine..does it go up? If the volts don't rise and you have water and clean connections your charging system may be in trouble.
Let us know what you find and we'll go from there.

If you need some hands on, let me know, I'm near Mayer.

Don H
Spring Valley AZ
'03 KLR 650/DS sidecar
DonD is offline  
post #3 of 4 Old 03-05-2010, 08:46 PM Thread Starter
1st Gear
 
Join Date: Jan 2010
Posts: 19
Ok,thanks , I will check the voltage, thanks again
ssknightrider is offline  
 
post #4 of 4 Old 04-25-2013, 03:07 PM
1st Gear
 
Join Date: Mar 2013
Posts: 19
KnightRider - did you ever find the solution to this? I'm having the very same symptoms on my 86 kl600. Thing is, it never had a battery, but when I first got it the headlight worked nice and bright the way it should, so it seems unlikely that a bad battery is the problem.
I also swapped out the R/R with no change.
Friedom is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gauge Lights tomatocity 1987 to 2007 Wrenching & Mods 5 07-18-2010 10:24 AM
back lights klrchris 1987 to 2007 Wrenching & Mods 1 10-25-2009 11:37 PM
Where do the 07 lights ground? JFG07 1987 to 2007 Wrenching & Mods 1 04-02-2009 05:10 PM
Flickering lights tcbb32 1987 to 2007 Wrenching & Mods 9 05-28-2008 05:21 PM
Lights and Console..... anvil67 1987 to 2007 Wrenching & Mods 0 12-25-2007 09:03 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome