'09 engine cutting out - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 07-13-2011, 04:39 PM Thread Starter
Neutral
 
Join Date: Jul 2010
Posts: 10
'09 engine cutting out

I am wondering if anyone has had a problem with their bike stalling when the handlebar is turned. I rode to work the other night and when I backed into the parking lot the bike died. I restarted it and rode around the parking lot and it kept stalling, so I thought maybe I had gotten bad gas as that had happened before. Long story short, the bike started right up in the morning and I was able to ride it the thirty miles home and when I turned the bike to back it into the garage it stalled again. I then noticed it would only stall when I turned the handlebars in either direction enough off center. I am assuming I have a wire chafing somewhere but have yet to troubleshoot it. I know this year is supposed to have some issues with wireing and was wondering if anyone else has had this problem.
rfischer71 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 07-13-2011, 05:17 PM
2nd Gear
 
kmbsar's Avatar
 
Join Date: Sep 2010
Location: San Jose, CA
Posts: 272
It sounds like a wiring issue to me, not that I know much. I'd turn the bar so it kills and check the continuity of your kill switch and your clutch handle safety switch.

:-/

PPMC #8

Ridin an 08 and loving every second of it
kmbsar is offline  
post #3 of 9 Old 07-13-2011, 08:12 PM
3rd Gear
 
SteelB12's Avatar
 
Join Date: Mar 2009
Location: NOVA
Posts: 562
My 09 had several rub points in the wiring. You should tear yours apart and start checking the wires. Remember to check behind the instrument panel.

Erik
2003 Bandit 1200S
2009 KLR 650

74 Honda CB360
SteelB12 is offline  
 
post #4 of 9 Old 07-13-2011, 09:15 PM
4th Gear
 
SLO-KLR's Avatar
 
Join Date: Sep 2006
Location: Paso Robles, CA.
Posts: 1,333
It is your choke cable. It is either too tight or hanging up on something. Check the adjustment and routing.
SLO-KLR is offline  
post #5 of 9 Old 07-16-2011, 08:51 AM Thread Starter
Neutral
 
Join Date: Jul 2010
Posts: 10
Found out that the ground wire from the ignition switch was broken inside its plastic jacket. They had not left much strain relief and it was being stretched when the handlebar was turned to the left. Problem is it broke about an inch away from the switch which makes repairing it somewhat difficult. I would really like to replace the entire harness but that looks pretty involved considering you have to drill out and replace the entire ignition switch. probably not cheap either. I've checked the website and my bike doesn't fall under any recalls.
rfischer71 is offline  
post #6 of 9 Old 07-16-2011, 12:34 PM
3rd Gear
 
SteelB12's Avatar
 
Join Date: Mar 2009
Location: NOVA
Posts: 562
Really?? I thought all 09s had the wiring harness recall. Well that just sucks.




Quote:
Originally Posted by rfischer71 View Post
Found out that the ground wire from the ignition switch was broken inside its plastic jacket. They had not left much strain relief and it was being stretched when the handlebar was turned to the left. Problem is it broke about an inch away from the switch which makes repairing it somewhat difficult. I would really like to replace the entire harness but that looks pretty involved considering you have to drill out and replace the entire ignition switch. probably not cheap either. I've checked the website and my bike doesn't fall under any recalls.

Erik
2003 Bandit 1200S
2009 KLR 650

74 Honda CB360
SteelB12 is offline  
post #7 of 9 Old 07-18-2011, 06:01 AM
1st Gear
 
Join Date: Jun 2011
Location: Redondo Beach,CA
Posts: 87
They did have the recall... well mine did at least (or so the original owner told me)
salty_monk is offline  
post #8 of 9 Old 07-18-2011, 06:38 AM
4th Gear
 
vatrader's Avatar
 
Join Date: Sep 2008
Location: Virginia
Posts: 1,263
Quote:
Originally Posted by rfischer71 View Post
Found out that the ground wire from the ignition switch was broken inside its plastic jacket. They had not left much strain relief and it was being stretched when the handlebar was turned to the left. Problem is it broke about an inch away from the switch which makes repairing it somewhat difficult. I would really like to replace the entire harness but that looks pretty involved considering you have to drill out and replace the entire ignition switch. probably not cheap either. I've checked the website and my bike doesn't fall under any recalls.

I don't know what VIN spread is covered by this recall, or how they are identifying the affected bikes. There are phone numbers you can call to confirm if yours if involved. Good luck.


http://www-odi.nhtsa.dot.gov/cars/pr...type=DrillDown

******
ďmany a trip continues long after movement in time and space have ceasedĒ- Steinbeck, [I]"Travels with Charlie"
[/I]
[IMG]http://i718.photobucket.com/albums/ww187/vatrader01/KLR%20mechanical/04e28c5e.jpg[/IMG]

[FONT="Century Gothic"][I]Sometimes your only available transportation is a leap of faith[/I] [/FONT]
vatrader is offline  
post #9 of 9 Old 07-18-2011, 07:37 AM Thread Starter
Neutral
 
Join Date: Jul 2010
Posts: 10
Thanks. I'll try that link. When I tried Kawasaki's website, it didn't list any recalls for my vin but I will make some calls to verify.
rfischer71 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
What engine oil are u using? Gitrdun 1987 to 2007 Wrenching & Mods 32 09-19-2016 12:23 AM
ENGINE NOISES SANS MOOSE ENGINE GUARD X6_Hustler 1987 to 2007 Wrenching & Mods 2 02-12-2010 02:29 AM
Harley cutting back production and jobs! TheWanderer KLR & Other Motorcycle Related Discussion 13 04-28-2008 12:08 PM
Noob with engine swap question....Will the KLR 650 engine fit in a KLR600? Juice_Man 1987 to 2007 Wrenching & Mods 0 04-01-2008 08:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome