08 Backfire but not the normal story? - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 05-11-2012, 01:29 PM Thread Starter
2nd Gear
 
Join Date: May 2010
Location: Kansas City
Posts: 224
08 Backfire but not the normal story?

Hello my KLR friends. I would like you input on an issue I am having with my ride. The bike is a KLR650 08 with 10,600 miles, I just purchased the bike a few months ago and had no known issues. When hot and only hot the bike backfires out the exhaust or pops in the air box but most troubling is that sometimes it backfires and rotates the motor back the incorrect dirrection it seems. When this happens you can hear the starter spin the motor over and then a violent stop and the starter makes the unmistakeable noise of not being able to turn the engine over. Background-The left engine cover has been off, I asked the last owner why and he said it was pulled to chack and adjust somethnig by the dealer and the carb has been adjusted. So what do you think guys? Valve adjustment, has the "DO" lost its tension, bad plug? I am changing the plug tonight however. When the bike is cool it never acts up, only when hot......Much thanks and have a good one all.

moriver is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 05-11-2012, 01:37 PM
2nd Gear
 
timothys687's Avatar
 
Join Date: Jul 2011
Location: Jackson, Michigan
Posts: 182
Send a message via MSN to timothys687 Send a message via Skype™ to timothys687
I would check the valves and do the .22 mod to the carb, I was having the same issues with my 09 at around 11000 miles, I took it to my motorcycle guru, and had him do both the valves were tight and the carb was way lean. Problem solved for me, good luck


Sent from my iPod touch using Motorcycle
Timothys687
More miles and smiles for all!
timothys687 is offline  
post #3 of 10 Old 05-11-2012, 03:08 PM
Moderator
 
klr4evr's Avatar
 
Join Date: Mar 2007
Location: Fort Sask , Alberta, Canada
Posts: 3,504
Garage
Send a message via Skype™ to klr4evr
Check the nuts that hold the header pipe onto the engine. I've lost one of those and when hot the motor backfired.

Don;t know what the dealer would be "adjusting" by removing the left case cover.

My Kaw Barn - 2004 KLR, 2006 Concours (sold), 1997 Bayou 400.

"It's a friggen motorcycle, it's not supposed to be comfortable, quiet or safe. The wind noise is supposed to hurt your ears, the seat should be hard and riding it should make you shit your pants every now and then. "

<--- Please fill in the 'Location' on your personal profile page. User CP/Edit Your Details

This information makes it much easier for other members to answer/comment on your posts.
klr4evr is offline  
 
post #4 of 10 Old 05-11-2012, 04:15 PM Thread Starter
2nd Gear
 
Join Date: May 2010
Location: Kansas City
Posts: 224
Timothys687- Yep the .22 cent mod is on the short list for the weekend just because I feel the need to mod this weekend.

klr4evr- I am with you. I hope the dealer just wrote "check and adjust" on an invoice checking to "DOO". My fear is to pull that cover and find a flat "flat rate special" kind of repair.
moriver is offline  
post #5 of 10 Old 05-11-2012, 06:34 PM
2nd Gear
 
terry_1956's Avatar
 
Join Date: Aug 2010
Location: Casper, WY
Posts: 389
Hearing a backfire in the airbox would be from firing with inlet valve open, from spinning backwards, timing to far advanced, or what is called dieseling from carbon build up heating to the point of firing on compression stroke with ignition off. Just some thoughts. Would definitely check valve clearance though.
terry_1956 is offline  
post #6 of 10 Old 05-11-2012, 08:31 PM
4th Gear
 
Spec's Avatar
 
Join Date: Apr 2010
Location: Gateway to Death Valley!
Posts: 1,928
Quote:
Originally Posted by moriver View Post
Hello my KLR friends. I would like you input on an issue I am having with my ride. The bike is a KLR650 08 with 10,600 miles, I just purchased the bike a few months ago and had no known issues. When hot and only hot the bike backfires out the exhaust or pops in the air box but most troubling is that sometimes it backfires and rotates the motor back the incorrect dirrection it seems. When this happens you can hear the starter spin the motor over and then a violent stop and the starter makes the unmistakeable noise of not being able to turn the engine over. Background-The left engine cover has been off, I asked the last owner why and he said it was pulled to chack and adjust somethnig by the dealer and the carb has been adjusted. So what do you think guys? Valve adjustment, has the "DO" lost its tension, bad plug? I am changing the plug tonight however. When the bike is cool it never acts up, only when hot......Much thanks and have a good one all.


The 08s had an issue called the deep hole. The starter idler shaft hole is drilled too deep and causes the gear to misalign. That would be my guess as to what's going on.

Backfire probably loose header connection.

No eye has seen, no ear has heard, no mind has conceived what God has prepared for those who love him. 1 Cor 2:9
Spec is offline  
post #7 of 10 Old 05-14-2012, 12:37 PM
1st Gear
 
Join Date: Apr 2012
Posts: 18
While I agree that 08's and some early 09's had the deep hole and it is an issue, I would look at the valves (especially if you haven't checked them yet.)
Buzzkill is offline  
post #8 of 10 Old 05-15-2012, 12:27 PM
4th Gear
 
Spec's Avatar
 
Join Date: Apr 2010
Location: Gateway to Death Valley!
Posts: 1,928
Quote:
Originally Posted by Buzzkill View Post
While I agree that 08's and some early 09's had the deep hole and it is an issue, I would look at the valves (especially if you haven't checked them yet.)

Yea the valves are tight probably. I was thinking about the weird starter behavior. If the shaft is sloppy in there I could see it moving the gears enough to engage something other than the starter motor.

No eye has seen, no ear has heard, no mind has conceived what God has prepared for those who love him. 1 Cor 2:9
Spec is offline  
post #9 of 10 Old 05-28-2012, 07:40 PM Thread Starter
2nd Gear
 
Join Date: May 2010
Location: Kansas City
Posts: 224
update

after much testing I think I have the problem about pinned down. I have found if I turn the gas off and then run the bike for a few seconds before turning it off then when starting the bike waiting to turn the fuel on till after the bike is running I have Zero symptoms. So I am guessing leaking shut off valve, plugged vent line or leaking seat in carb? The shut off valve was on the list for a mod so we will start with it.
moriver is offline  
post #10 of 10 Old 05-28-2012, 08:12 PM
Banned
 
Join Date: Jan 2010
Location: Mid-Atlantic
Posts: 763
If the carb float valve is fully functional, petcock shutoff machts nichts (makes no difference). The absence of the problem when you manipulate the petcock may be coincidental.

Most likely diagnosis, seems to me from symptoms, header air leak compounded when hot (from metal expansion).

Ain't likely ignition timing (geometrically fixed); backfires usually a result of improper air/fuel mixture.

Ever adjust fuel screw? About 1.75 out from a soft bottoming, for a neo-stock engine.
LoneRider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Backfire? sammy 2008+ KLR650 Wrenching & Mod Questions 3 05-27-2010 11:02 PM
09' Minor Backfire after L-MOD, and Baffle removal DUBL-A 2008+ KLR650 Wrenching & Mod Questions 6 03-10-2010 08:47 PM
Help needed on backfire and idle wilk 1987 to 2007 Wrenching & Mods 2 07-03-2009 03:29 PM
Backfire after Mod? Ne14abeer 2008+ KLR650 Wrenching & Mod Questions 2 02-23-2009 08:47 PM
Backfire under deceleration feelthelove 1987 to 2007 Wrenching & Mods 7 03-19-2008 06:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome