changed the oil and now it wont start - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 Old 07-30-2012, 12:09 PM Thread Starter
Neutral
 
Join Date: Jul 2012
Posts: 8
changed the oil and now it wont start

hey guys, its my first time changing the oil on my klr that i bought a couple weeks ago. i changed the oil and the oil filter. i let it run for a bit yesterday after i finished. i get on the bike today and it wont turn over plus gives me a buzzing noise from the carburetor area.

what is going on? what could i have possibly done? (drain oil, replace filter, replace oil plug, fill with oil(4cycle 10w-40)

please help.
joshuacohen is offline  
Sponsored Links
Advertisement
 
post #2 of 16 Old 07-30-2012, 12:42 PM
3rd Gear
 
steferf's Avatar
 
Join Date: Jun 2010
Location: Rolla, Mo
Posts: 576
The Carburator is close to the starter motor.

Is it possible the starter motor is the source of the buzz? You could place your hand on the starter motor to feel for vibrations.

2006 Red KLR 650

Modifications:
1)Doohickey Planned and purchased 2)Aftermarket Grips 3)Grip Heaters 4)Happy Trails Hard Luggage Rack 5)20 mm ammo cases planned soon 6)Aftermarket Exhaust 7)Thermobob 8)Happy Trails Fork Brace 9)Stainless Steel Oil Filter 10)Magnetic Drain Plug

See profile visitors post for details and planned mods.
steferf is offline  
post #3 of 16 Old 07-30-2012, 12:46 PM Thread Starter
Neutral
 
Join Date: Jul 2012
Posts: 8
hmm to be honest im not sure. i have it set up to charge the battery right now, as per anothers suggestion. but i would say that there is definitely a buzz and a vibration (perhaps from aft of the carb.)
joshuacohen is offline  
 
post #4 of 16 Old 07-30-2012, 01:52 PM
Banned
 
Join Date: Jan 2010
Location: Mid-Atlantic
Posts: 763
JUMP your battery with a hot automobile battery and see what happens; my suggestion.

Year KLR?
LoneRider is offline  
post #5 of 16 Old 07-30-2012, 08:20 PM Thread Starter
Neutral
 
Join Date: Jul 2012
Posts: 8
i was able to push start it earlier today and it started up. i let it run for a good 20 minutes. it appears to be starting up (with the start button) but still a series of those quick battery clicks just before it turns over completely. should i assume i have a battery problem? im gonna get it checked out tomorrow.

ive narrowed down that the buzzing noise is battery related. correct?
joshuacohen is offline  
post #6 of 16 Old 07-30-2012, 08:48 PM
1st Gear
 
Join Date: May 2012
Location: Adelaide - South Australia
Posts: 42
I would say the buzzing noise is the starter relay which is located under the black cover L/H side down near carbi. A dud battery with low volts could not quite have enough power to throw the relay and hold it, instead it "buzzes" back and forth, my WR450 does exactly this if the battery gets low. Or if battery has good voltage the relay its self may be stuffed or battery has a bad earth.

Last edited by 270win; 07-30-2012 at 08:49 PM. Reason: spelling
270win is offline  
post #7 of 16 Old 07-30-2012, 08:51 PM
Missed Gear
 
Cabrito's Avatar
 
Join Date: Feb 2011
Location: 415&707
Posts: 1,193
Could be totally coincidental. Same thing happened to me once right after I changed the oil. Pull the battery and check fluid level.
I found mine was really low and even when I filled it up it wouldn't hold a charge.

Sent from my rotary phone
================================
Track me here -
https://spotwalla.com/tripViewer.php...354a61e5f3997a
Michael G in SF | 2018 KTM 1090R Adventure | 02 XR400R (Plated) | 2011 FJ Cruiser Army Green |
------------------------------------------------------------
"If you have the will and not the way, you wont get very far."
Snakeboy66

Last edited by Cabrito; 07-30-2012 at 10:12 PM.
Cabrito is offline  
post #8 of 16 Old 07-30-2012, 09:19 PM
Lifetime Member
 
650Stew's Avatar
 
Join Date: Jun 2010
Location: Alberta, Canada
Posts: 2,480
Another vote for the battery here, KLR's like lotsa juice

650Stew is offline  
post #9 of 16 Old 07-30-2012, 09:25 PM
4th Gear
 
larry31's Avatar
 
Join Date: Aug 2009
Location: New Hampshire
Posts: 1,063
Have you checked your battery terminals? Are they clean and tight?

Loose or bad terminal connections can make the starter relay "chatter".

Ageing Gracefully



2017 Yamaha XT250
1990 Honda NX250 (Green/White)
2011 Kawasaki KLR 650 (Orange & White )

My KLR Page..http://www.powers31.info/2011_KLR650.htm

Mod's to KLR:
Power socket, L.E.D. Battery Indicator, Camera bag holder
Custom Saddlebag frames .
Louder horns, Firstgear Onyx tail bag.
Custom Aluminum Skid Plate.
Cut down seat with Custom pad.
Go Pro Camera mount.
Doo-Hicky
larry31 is offline  
post #10 of 16 Old 07-31-2012, 12:09 AM
Banned
 
Join Date: Jan 2010
Location: Mid-Atlantic
Posts: 763
I previously suggested a test procedure that would identify, with some certainty, whether your electrical storage and/or generation system (i.e., battery and alternator/rectifier) might be the problem (i.e., JUMP the battery with a known hot battery).

Good luck!

Last edited by LoneRider; 07-31-2012 at 05:53 PM.
LoneRider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
01 wont start Beardyman 1987 to 2007 Wrenching & Mods 8 05-02-2012 09:09 AM
wont start!! help!! wnc/mtn=klr 1987 to 2007 Wrenching & Mods 7 04-29-2012 08:35 PM
93 KLX650R wont start insane_postman Other KLR's - 250, 600, Tengai, C Models, KLX... 5 02-13-2012 09:58 PM
bike wont start TEXAS 650 1987 to 2007 Wrenching & Mods 20 05-18-2008 07:09 PM
Bike wont start blprince 1987 to 2007 Wrenching & Mods 6 07-25-2007 08:19 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome