Headlight issue - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 10-07-2012, 03:26 PM Thread Starter
Neutral
 
Join Date: Oct 2012
Location: Hampton, VA
Posts: 6
Headlight issue

OK, so i have an interesting one for you guys. the low beam headlight in my KLR basically works when it wants to. When you turn on the bike it does not come on, it will eventually come on after a while, or if you reach up inside and push on the back of the plug it will come on and stay on for hours, but if you turn the bike off for more then about 15 seconds, it won't come back on until you start riding for a while or reach up inside again? thoughts? and i have already checked no corrosion.

Thanks in advance for any help
Jeeprogue is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 10-07-2012, 03:49 PM
Lifetime Member
 
flash's Avatar
 
Join Date: May 2008
Location: North Texas
Posts: 1,534
Send a message via Yahoo to flash
Simple things first. Replace the bulb. Could be a broken filament intermittently contacting.
flash is offline  
post #3 of 11 Old 10-07-2012, 03:50 PM Thread Starter
Neutral
 
Join Date: Oct 2012
Location: Hampton, VA
Posts: 6
I have already tried replacing the bulb
Jeeprogue is offline  
 
post #4 of 11 Old 10-07-2012, 03:53 PM
2nd Gear
 
ArcticKLR's Avatar
 
Join Date: Feb 2012
Location: No. CA
Posts: 366
Sounds like a wiring issue IMHO. Does your high beam work similarly or does it work all the time? If the HB works all the time you should be able to rule out the fuse as well as narrow down the potential problem to the separate wiring for the LB.
I would star with the headlight itself and trace backwards. Start with the stabilizing clip, if that's gone the light could theoretically wiggle back and forth which would cause intermittent issues. Then follow wiring and see if there is any chafing anywhere. Also have you checked the bulb itself? If it is older it may have an issue inside and be ready to burn out, you should be able to check that just by pulling the bulb. Just some thoughts. Good luck with tracing it.


Sent from my Motorcycle iPhone app
ArcticKLR is offline  
post #5 of 11 Old 10-07-2012, 04:03 PM Thread Starter
Neutral
 
Join Date: Oct 2012
Location: Hampton, VA
Posts: 6
Thanks for the responses so far, the high beam functions perfectly with no issues. i wouldn't say that the problem is intermittent because it's predictable. it comes on and stays on every time you hit the plug, and every time you turn it off for more then 15 seconds it doesn't come back on until its been ridden for a while or you hit the plug again.
Jeeprogue is offline  
post #6 of 11 Old 10-07-2012, 04:04 PM
Lifetime Member
 
flash's Avatar
 
Join Date: May 2008
Location: North Texas
Posts: 1,534
Send a message via Yahoo to flash
Right, start tracing it back. I don't believe the KLR has a headlight relay so I'd be looking for chafed wires, the hi-lo switch, and the fuse.
flash is offline  
post #7 of 11 Old 10-07-2012, 04:09 PM
Lifetime Member
 
650Stew's Avatar
 
Join Date: Jun 2010
Location: Alberta, Canada
Posts: 2,480
Almost sounds like a broken/nearly broken wire in the plug? Just guessing on my part.

650Stew is offline  
post #8 of 11 Old 10-07-2012, 04:46 PM Thread Starter
Neutral
 
Join Date: Oct 2012
Location: Hampton, VA
Posts: 6
Thats what i was thinking, is it possible to replace just the end on it or does the whole harness have to be replaced?
Jeeprogue is offline  
post #9 of 11 Old 10-07-2012, 06:20 PM
4th Gear
 
Spec's Avatar
 
Join Date: Apr 2010
Location: Gateway to Death Valley!
Posts: 1,928
Quote:
Originally Posted by Jeeprogue View Post
Thats what i was thinking, is it possible to replace just the end on it or does the whole harness have to be replaced?

+1 on simple things first, after the bulb check the switch.

No eye has seen, no ear has heard, no mind has conceived what God has prepared for those who love him. 1 Cor 2:9
Spec is offline  
post #10 of 11 Old 10-07-2012, 06:44 PM
1st Gear
 
Ecip's Avatar
 
Join Date: Mar 2012
Posts: 91
Hmm the switch doesn't turn on through Low beams thought, so my finger is also on a lose connection near the light bulb.

Sent from my SGH-I747M using Motorcycle.com Free App
Ecip is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Steering issue mwatson 2008+ KLR650 Wrenching & Mod Questions 6 09-04-2011 10:01 PM
Idle Issue sh1bby69 2008+ KLR650 Wrenching & Mod Questions 2 08-28-2011 09:40 PM
Headlight Issue 06 KLR650 leogear KLR & Other Motorcycle Related Discussion 13 08-16-2011 07:20 PM
Still the same stalling issue. Northerner28 1987 to 2007 Wrenching & Mods 2 06-08-2008 03:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome