Slow start - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 11-14-2012, 09:58 AM Thread Starter
1st Gear
 
Join Date: Nov 2012
Posts: 32
Slow start

My 2008 has been running great. lately it's been hard to start. just now while trying to start it it back fired (really loud) and still did not start. any ideals..really new to this. It has 12000 miles and I bought it about 3 months ago. This is the first problem. Thanks
rlamp4040 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-14-2012, 10:34 AM
OverDrive
 
Join Date: Jan 2011
Location: NW MO
Posts: 5,339
Does it crank over good but just take longer to start?

Sounds to me like perhaps your valves need a check/adjustment. Do you know if that's ever been done on your KLR?



planalp is offline  
post #3 of 5 Old 11-14-2012, 04:14 PM Thread Starter
1st Gear
 
Join Date: Nov 2012
Posts: 32
It cranks over but just wont start. I push started it and it started right up. I found out that nothing has been done to it yet other then oil changes regularly. I tried started it a few minyes ago and it started right up. Should I get it tuned up.Checked out.
rlamp4040 is offline  
 
post #4 of 5 Old 11-14-2012, 04:37 PM
4th Gear
 
Join Date: Oct 2006
Location: Pefferlaw,Ontario
Posts: 1,636
IIRC....wasn't some of the 08's plagued with the decompressor mechanism too thick and thusly holding the exhaust valve open slightly resulting in lack of good compression....? Possibly not enough to fire?

Please forgive....I had to take some meds I haven't needed for some time....and very groggy.

The fix was to shave a hair off the dowel that holds the shim bucket down....if this is the cause...that is.

Damn these meds are strong!!!

Willys
willys is offline  
post #5 of 5 Old 11-14-2012, 05:40 PM
1st Gear
 
PA_KLR's Avatar
 
Join Date: Mar 2011
Location: PA
Posts: 49
Try starting it with side stand up

My 08 was doing the same thing. I found that if I put the side stand up it would start every time. The problem was that with the side stand down the bike relies on the neutral switch for ground and it was not always supplying a good ground. I replaced the neutral switch and still have the same problem once in a while. But with the side stand up it never gives me a problem. Keep in mind the side stand switch is engaged when the stand is up, so it is working.
PA_KLR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 klr 650 way too slow,,,what do i need dealzzalot 2008+ KLR650 Wrenching & Mod Questions 39 11-28-2016 11:39 AM
Kinda slow in here... Spec Jokers Lounge 5 01-11-2012 12:23 PM
Stalling when I slow down... abbysdaddy 1987 to 2007 Wrenching & Mods 4 08-23-2011 10:31 PM
slow to return to idle. DRAGON997 2008+ KLR650 Wrenching & Mod Questions 6 02-23-2010 10:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome