Front Engine Mount Blues - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 06-19-2013, 09:14 PM Thread Starter
2nd Gear
 
Join Date: Oct 2012
Location: Silver City, NM
Posts: 217
Front Engine Mount Blues

Some months ago I put the HT footpeg/engine protector on my '11 and since it comes with a front engine mount welded on as part of it, I removed the original mounts and put them away. (I never ever, double never ever throw anything out. I'm a terminal pack rat)

OK, a few weeks ago I installed the SW Motech crash bars and it was more than a bit of a struggle getting them on with the footpeg brace in the way. With some good salty language and a mighty heave I got them mounted, but now I have more vibration since the metal components are jammed together.

Sooo......today I thought "phooey on it" and went for the old mounts to put back on. Then I'd see about re-drilling mounting holes for the foot peg bar.

You guessed it - can't find them. Got muffler, front springs, rear springs, etc., on and on.....but no front engine mounts. Tore that shop apart and no mounts.

Finally, looking on-line for new ones the ones I'm seeing on the parts breakdowns all show an L shaped front engine mount and I don't remember seeing that on mine. Looked on bike and see nothing the L would attach to. I'm "pretty sure" the original mounts were just a plain triangle.

Looking on eBay I see a set for an '05 that look like mine but does the '05 front engine mount have the same bolt spacing as the '11 ?? Help Help Help..............Lar.

Last edited by biglar; 06-19-2013 at 09:16 PM.
biglar is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 06-19-2013, 10:28 PM
4th Gear
 
Spec's Avatar
 
Join Date: Apr 2010
Location: Gateway to Death Valley!
Posts: 1,928
Quote:
Originally Posted by biglar View Post
Some months ago I put the HT footpeg/engine protector on my '11 and since it comes with a front engine mount welded on as part of it, I removed the original mounts and put them away. (I never ever, double never ever throw anything out. I'm a terminal pack rat)

OK, a few weeks ago I installed the SW Motech crash bars and it was more than a bit of a struggle getting them on with the footpeg brace in the way. With some good salty language and a mighty heave I got them mounted, but now I have more vibration since the metal components are jammed together.

Sooo......today I thought "phooey on it" and went for the old mounts to put back on. Then I'd see about re-drilling mounting holes for the foot peg bar.

You guessed it - can't find them. Got muffler, front springs, rear springs, etc., on and on.....but no front engine mounts. Tore that shop apart and no mounts.

Finally, looking on-line for new ones the ones I'm seeing on the parts breakdowns all show an L shaped front engine mount and I don't remember seeing that on mine. Looked on bike and see nothing the L would attach to. I'm "pretty sure" the original mounts were just a plain triangle.

Looking on eBay I see a set for an '05 that look like mine but does the '05 front engine mount have the same bolt spacing as the '11 ?? Help Help Help..............Lar.

The "L" is to attach the OEM plasitc skid plate.

No eye has seen, no ear has heard, no mind has conceived what God has prepared for those who love him. 1 Cor 2:9
Spec is offline  
post #3 of 6 Old 06-20-2013, 12:22 AM Thread Starter
2nd Gear
 
Join Date: Oct 2012
Location: Silver City, NM
Posts: 217
Quote:
Originally Posted by Spec View Post
The "L" is to attach the OEM plasitc skid plate.
Ah, sooo, thankee. Is the '05 mount the same dimensions as the '11 ??
biglar is offline  
 
post #4 of 6 Old 06-20-2013, 01:33 AM
5th Gear
 
Join Date: Oct 2011
Location: Lac La Biche Alberta Canada
Posts: 3,205
Quote:
Originally Posted by biglar View Post
Ah, sooo, thankee. Is the '05 mount the same dimensions as the '11 ??
My '11 and my '03 are the same dimensions on the bolt holes Lar. I have my stocker '11s I am not using will give you if you want to wait for the shipping time. Would be about 2 weeks from here to there. I may have some left over '03 flat plates too if they would help.
Regards....justjeff

It's not a Tractor....It's a LOCOMOTIVE!! Chugga Chugga
Woooo WOOOOO!!!!!
justjeff is offline  
post #5 of 6 Old 06-20-2013, 06:44 AM
4th Gear
 
Join Date: Oct 2006
Location: Pefferlaw,Ontario
Posts: 1,636
Big...when you installed the crash bars, you needed to not use a set of spacers and the whole thing will fit without forcing it. Ask me how I learned...doh!!! I also forced a set together only to get so frustrated that I tried it without the spacers and it fit like a glove! Please don't ask which spacers I left out but it works like a charm. They don't explain this very well from what I do remember.
As for the engine mounts between the two gen bikes, they are all the same but the formed L bracket you are describing is spot welded onto the main engine mount. It can be removed and you are left with the stock first gen mount, again, ask me how I know...lol. The bolt hole spacing is the same but at the moment I am thinking IF the thickness is the same which made it easier to use the stock mount without the spot welded bracket attached to them?
I'm sorry I can't remember what spacer I left out but I do know the whole system will fit easily and you don't need to force anything once you do figure out which item to leave out.
I had a rough day yesterday and my head isn't very clear yet.....sorry. Meds...

Willys
willys is offline  
post #6 of 6 Old 06-20-2013, 09:15 PM Thread Starter
2nd Gear
 
Join Date: Oct 2012
Location: Silver City, NM
Posts: 217
Quote:
Originally Posted by justjeff View Post
My '11 and my '03 are the same dimensions on the bolt holes Lar. I have my stocker '11s I am not using will give you if you want to wait for the shipping time. Would be about 2 weeks from here to there. I may have some left over '03 flat plates too if they would help.
Regards....justjeff
Thanks, Jeff. I'll PM you right now.................Lar.
biglar is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
wtb 09 plastic front engine shroud dean1965 2008+ KLR650 Wrenching & Mod Questions 2 08-06-2012 04:53 PM
Wash Board Blues... LittleSteve KLR & Other Motorcycle Related Discussion 4 06-01-2012 10:32 PM
Bikes Blues & BBQ 10/3-10/6 Fayetteville, AR. JoMoKLR Mid-West Riders 0 09-07-2007 10:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome