thermastat hose? - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-06-2014, 11:54 AM Thread Starter
Neutral
 
watchmaker's Avatar
 
Join Date: Nov 2013
Location: Blaine,Wa.
Posts: 5
thermastat hose?

I have an 08 klr 650.....the hose from thermastat is leaking a bit due to age and heat from being right above exhaust.....have checked with Kawasaki dealer and the really dont show it in the slides they have and no one seems to know for sure what part number it is....was wondering if anyone has ever replaced theres and what kawi part number it was or if they went with something after market?...wanting to get this problem resolved before oregon coast trip the end of june.....thx for any help/info

West
watchmaker is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-06-2014, 12:37 PM
Moderator
 
klr4evr's Avatar
 
Join Date: Mar 2007
Location: Fort Sask , Alberta, Canada
Posts: 3,481
Garage
Send a message via Skype™ to klr4evr
I think the part you are wanting is - 39062-0148

Your dealer needs to be looking at the parts related to the radiator.


My Kaw Barn - 2004 KLR, 2006 Concours (sold), 1997 Bayou 400.

"It's a friggen motorcycle, it's not supposed to be comfortable, quiet or safe. The wind noise is supposed to hurt your ears, the seat should be hard and riding it should make you shit your pants every now and then. "

<--- Please fill in the 'Location' on your personal profile page. User CP/Edit Your Details

This information makes it much easier for other members to answer/comment on your posts.
klr4evr is offline  
post #3 of 4 Old 05-06-2014, 03:03 PM Thread Starter
Neutral
 
watchmaker's Avatar
 
Join Date: Nov 2013
Location: Blaine,Wa.
Posts: 5
well...found out via another forum......I have a bit diffrent set up than stock....as I have a Thermo-Bob Kit installed on my bike......this answers the questions as to why it does not look like what was shown in Kawi slides.......at least I now have answers and can go forward in replacing the hose with the stock one and just making a cut in stock hose and re-installing it, just a bit shorter than stock due to kit......
watchmaker is offline  
 
post #4 of 4 Old 05-06-2014, 03:13 PM Thread Starter
Neutral
 
watchmaker's Avatar
 
Join Date: Nov 2013
Location: Blaine,Wa.
Posts: 5
well...found out via another forum......I have a bit diffrent set up than stock....as I have a Thermo-Bob Kit installed on my bike......this answers the questions as to why it does not look like what was shown in Kawi slides.......at least I now have answers and can go forward in replacing the hose with the stock one and just making a cut in stock hose and re-installing it, just a bit shorter than stock due to kit......
watchmaker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
What's this hose. D C 2008+ KLR650 Wrenching & Mod Questions 7 10-12-2013 01:58 AM
Front brake hose Millhouse 1987 to 2007 Wrenching & Mods 0 08-23-2013 07:14 AM
KLR600 front brake hose Millhouse Other KLR's - 250, 600, Tengai, C Models, KLX... 2 08-10-2013 08:17 PM
Vacuum hose size? tomatocity 1987 to 2007 Wrenching & Mods 0 03-31-2010 02:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome