Denali Horn Relay Just Clicks - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-14-2015, 01:13 PM Thread Starter
1st Gear
 
apexal's Avatar
 
Join Date: Feb 2015
Location: Dover, NH
Posts: 27
Denali Horn Relay Just Clicks

I bought a Denali Soundbomb Dual-Tone air horn along with with the plug-and-play wiring kit and mounting bracket for my KLR. It's a pretty simple and straight-forward installation but my horn does not work. I simply get a clicking noise from the relay, nothing more. I double checked everything but for the life of me can't figure out what the problem is. The wiring kit includes a plug to the relay so all that's left is to connect on lead to the battery, one to the positive on the horn, and two leads to the existing horn wires. Earlier today I installed a Wolo air horn and wiring kit on my R1200GS and I had no problems there so I figure that I'm at least partially capable of installing a horn. Does anybody have any ideas on what my problem might be? Thanks in advance.


Denali SoundBomb Compact Dual-Tone Air Horn - TwistedThrottle.com

Denali Plug-N-Play wiring kit for Denali SoundBomb Compact Dual-Tone Air Horn & Stebel Air Horn - TwistedThrottle.com

2014 KLR650 - White

2014 BMW R1200GS - Red
apexal is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-14-2015, 01:34 PM
Lifetime Member
 
650Stew's Avatar
 
Join Date: Jun 2010
Location: Alberta, Canada
Posts: 2,480
Sounds like one of the wires is connected up wrong? Does the wiring look like this?
http://www.pakwheels.com/forums/atta...untitled-1.jpg

650Stew is offline  
post #3 of 3 Old 06-14-2015, 04:24 PM Thread Starter
1st Gear
 
apexal's Avatar
 
Join Date: Feb 2015
Location: Dover, NH
Posts: 27
It's fixed. I had a spare relay and tried swapping that out. The brand new relay that came with the Denali horn apparently was defective. Other than way too much wire in the kit the setup is nice and the horn is nice and loud!

2014 KLR650 - White

2014 BMW R1200GS - Red
apexal is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Denali D-4 LED lamps on 2014 KLR jaimesix How To's & Tech Guides 11 02-17-2016 05:55 PM
Fan Relay Millhouse 1987 to 2007 Wrenching & Mods 3 08-29-2013 11:51 AM
Denali 2 lighting mod davo-55 2008+ KLR650 Wrenching & Mod Questions 8 09-03-2011 03:23 PM
Denali Hwy with a side of Hatchers Pass KLRless Travel Log & Trip Reports 15 06-22-2008 03:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome