Throttle won't move after new grips installed - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-28-2008, 11:07 AM Thread Starter
2nd Gear
 
Join Date: Mar 2008
Location: Oregon
Posts: 160
Send a message via Yahoo to Kawi_KLR650
Throttle won't move after new grips installed

I installed new grips this weekend and when I came out in the morning to go to work the throttle wouldn't move. It would move but i had to use a lot of muscle. I don't know what I did wrong. Please help. Thank you.
Kawi_KLR650 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-28-2008, 03:38 PM
1st Gear
 
Join Date: Oct 2006
Location: Colorado
Posts: 93
Did you use grip glue? Maybe too much glue.

If you used no glue (I never use any), then something is binding.

Do you have lever guards installed? Make sure the end of the throttle grip isn't rubbing on the guard.

Did you take the grip/throttle tube off? Make sure the cables are still routed correctly. Make sure nothing got inside the throttle tube and is rubbing on the handlebars.

Maybe the new grips are rubbing on the lever housing (next to your thumb). I've had to trim some grips before to avoid this.
SgtMarty is offline  
post #3 of 4 Old 07-29-2008, 11:51 AM Thread Starter
2nd Gear
 
Join Date: Mar 2008
Location: Oregon
Posts: 160
Send a message via Yahoo to Kawi_KLR650
I must have used too much glue. I wont use any on the throttle grip anymore. I took it apart and cleaned everything up. works great now.
Kawi_KLR650 is offline  
 
post #4 of 4 Old 07-29-2008, 01:15 PM
4th Gear
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
Hairspray works wonders letting the grip slide on and then when it dries it acts like a glue, but won't cause any binding.
DXKLR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed the lowering links Northman 1987 to 2007 Wrenching & Mods 3 09-12-2008 07:27 AM
Installed Studebaker W/jet kit jusmoov 1987 to 2007 Wrenching & Mods 11 08-12-2008 04:45 AM
Installed engine guards, left overs??? myhrdly 1987 to 2007 Wrenching & Mods 6 06-21-2008 10:15 PM
Patman recommended bar risers installed. Timbo KLR & Other Motorcycle Related Discussion 0 06-30-2007 01:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome