Bad Blinker Housing - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 Old 08-03-2008, 08:19 AM Thread Starter
Guest
 
Join Date: Aug 2008
Posts: 1
Bad Blinker Housing

I bought an 08 KLR in Aug 07 and since then I have had three blinker housings break. Not knocked off just fall off. The bike is gargae kept. It's like the rubber is bad maybe a bad mix at the molding factory. The dealership replaced one for free the bike only had 600 miles on it then now it has 1000. Has anyone else had this problem. Wondering if this is a factory recall.
myassisadragon is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 08-03-2008, 09:45 AM
Moderator
 
klr4evr's Avatar
 
Join Date: Mar 2007
Location: Fort Sask , Alberta, Canada
Posts: 3,561
Garage
Send a message via Skype™ to klr4evr
I've heard that myself. Some guys are replacing them with Buell units that are much cheaper than Kawi's. Don't know what's involved modification wise though.

My Kaw Barn - 2004 KLR, 2006 Concours (sold), 1997 Bayou 400.

"It's a friggen motorcycle, it's not supposed to be comfortable, quiet or safe. The wind noise is supposed to hurt your ears, the seat should be hard and riding it should make you shit your pants every now and then. "

<--- Please fill in the 'Location' on your personal profile page. User CP/Edit Your Details

This information makes it much easier for other members to answer/comment on your posts.
klr4evr is offline  
post #3 of 14 Old 08-03-2008, 11:32 AM
4th Gear
 
DXKLR's Avatar
 
Join Date: May 2007
Location: Richmond, Ky
Posts: 1,980
Yeah another member in here had same issue losing his blinkers while riding. Would get home and it would just be gone. I think he ordered some low profile units and hadn't had any more problems since. I hope he'll make a post if he see's this.
DXKLR is offline  
 
post #4 of 14 Old 08-04-2008, 03:30 PM
2nd Gear
 
Join Date: Jun 2008
Location: DFW area Texas
Posts: 116
I bought an 08 from a guy that had replaced one, and the other one is duct taped on. His two buddies both bought 08's at the same time, and all three bikes have had indicators break off. I was told it usually happened at about 70mph on highways.
The dealer here has one on order for me, and so far the duct tape is performing well.
That's all I know about it.
hornetguy is offline  
post #5 of 14 Old 08-05-2008, 07:39 AM
Guest
 
Join Date: Mar 2008
Posts: 16
Bad Indicator mounting

Bought a new bike in Feb 08. It didn't even have 200 km on when the left rear indicator rubber mounting disintegrated. Dealer replaced it under the factory warranty, apparently it was a bad molding from the supplier. Since then 9500 km on the bike with no problem.
Totos is offline  
post #6 of 14 Old 08-06-2008, 01:11 PM
Neutral
 
Join Date: May 2008
Posts: 6
Same Thing With My 08 All 4 In Fist 800 Miles. My Dealer Was $51 Found Some Off Ebay From Zx6r Got 4 For Under $50. I Think It Was A 06 Model They Fit Perfect.
highpockets is offline  
post #7 of 14 Old 08-09-2008, 01:37 PM
2nd Gear
 
Join Date: Jun 2008
Location: DFW area Texas
Posts: 116
apparently the curse is still working. Went outside this am, and found my front left indicator dangling. I didn't even ride it yesterday because of predicted thunderstorms.
Plano dealership says Kawi is backordered on the rears, but doesn't know about the fronts... He's going to check.
I'm going to look for replacements.

Does anybody know if the older model KLR indicators work?
If not, I guess it's ebay and possibly Buell...
This is frustrating.
hornetguy is offline  
post #8 of 14 Old 08-09-2008, 06:37 PM
Guest
 
Join Date: May 2008
Posts: 31
Yes Chief,

I'm still waiting for my 4th replacement..its front right.
BrassMonkey is offline  
post #9 of 14 Old 08-10-2008, 01:55 PM
Guest
 
Join Date: Jul 2008
Posts: 11
Second set will arrive this week

My dealer was great once I provided forum evidence that Kawasaki was replacing the broken blinkers under warranty.
Replaced both rear blinkers two months ago. Front set are on back order with the dealer.

Dealer said they are now a different part number, but I can't tell if there is a difference between new and old.

I will replace all with an aftermarket in the future. Anyone have ideas?
revog is offline  
post #10 of 14 Old 08-11-2008, 08:09 AM
2nd Gear
 
Join Date: Jun 2008
Location: DFW area Texas
Posts: 116
only one left, now. When I was carrying my fairing into the house to try to insert my semi-repaired broken left front, the right front fell off.
I had used RTV to try to repair the left one (didn't hold very well) and then wrapped it with electrical tape. I inserted it, and then taped it all up with good ol duct tape.... didn't have to use any baling wire, though.
So now I have a fairly new KLR with three of the four turn indicators "bubba'd" back in place, just to be able to drive legally.
I'm including pics of the RTV'd left one, that broke off at the base, and the broken right one, that broke in the middle. (made duct taping a little easier)
You can see the hairline thru the RTV on the left one.


hornetguy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Choke Housing jredford Gadgets & Gizmos 4 06-18-2008 04:54 PM
Anybody know where to get hollow allthread for blinker stalk ironbrewer 1987 to 2007 Wrenching & Mods 6 10-07-2006 07:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome