2009 klr stalls with twist of throttle - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 01-11-2016, 12:36 PM Thread Starter
Neutral
 
gatorrider's Avatar
 
Join Date: Dec 2015
Posts: 8
2009 klr stalls with twist of throttle

Hi everyone,
Just picked up a 2009 klr 650 for 1,200 bucks. Prolem is it has hibernation sickness! This bike only has 2,166 miles on it. The guy bought it new, fell off twice. The 2nd fall broke his collar bone.
He put it in storage and it just sat til I came along.
The battery was shot but my main problem is the carb! I bought a new carb kit cause the gaskets were hard and brittle and I gave it a good pine sol soak. This made it look clean as hell.

I cleaned the air filter. I checked the fuel lines and the vent lines. They are all clear. I changed the spark plug and did notice the plug had black soot on it but it was dry. I figured it has to be running rich. To me that means the float is allowing to much fuel in the bowl. Tried the seafoam and no change.

I must have had that thing off 6 times. The diaphram doesnt have any holes.
The bike does start easy but idles eratic even after warm up..

This carb seems very easy to work on but its kicking my butt. Im out of ideas any help woulb be great.
gatorrider is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 01-11-2016, 05:24 PM Thread Starter
Neutral
 
gatorrider's Avatar
 
Join Date: Dec 2015
Posts: 8
So after taking a break, I reopened the carb and noticed that I did something very stupid! I placed the needle jet on top of the spring seat . It of course it needs to go into the bottom of the diaphram then seat spring, then the spring. I feel stupid because I had that thing apart 6-7 times.
gatorrider is offline  
post #3 of 12 Old 01-11-2016, 08:41 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,323
gatorrider,,
Glad that you figured out your error.

Now I will ask a simple question. Did you Thoroughly Re-Oil your air filter after cleaning?

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 84,000+ miles & counting
pdwestman is offline  
 
post #4 of 12 Old 01-11-2016, 09:07 PM
1st Gear
 
ReadyToBugout's Avatar
 
Join Date: Oct 2014
Location: Idaho
Posts: 93
Garage
And I assumed the problem is fixed, jes?

2014 Green/Black KLR650 "New Edition"
2006 Yamaha Cherry Red FZ1
2007 Yamaha VStar 1100 (Wifes, but I've ridden it more than her)
ReadyToBugout is offline  
post #5 of 12 Old 01-12-2016, 07:13 AM Thread Starter
Neutral
 
gatorrider's Avatar
 
Join Date: Dec 2015
Posts: 8
Quote:
Originally Posted by pdwestman View Post
gatorrider,,
Glad that you figured out your error.

Now I will ask a simple question. Did you Thoroughly Re-Oil your air filter after cleaning?
I did re-oil the filter, thanks for asking
gatorrider is offline  
post #6 of 12 Old 01-12-2016, 07:23 AM Thread Starter
Neutral
 
gatorrider's Avatar
 
Join Date: Dec 2015
Posts: 8
Quote:
Originally Posted by ReadyToBugout View Post
And I assumed the problem is fixed, jes?
Well yes, it started and ran really well..then I took it down and put gas in it( 94octane). After that, I got it up to a sustained speed of about 60mph. However, when I had to downshift. I noticed that it started stalling. This was really unexpected as it was running perfect.
So, im gonna see if I fouled my new spark plug up while trying to start it when it was too rich . Im sure I messed something up..lol. It ran soooo good though. Not sure how after putting high octane in it that it would start running like sh*t.
gatorrider is offline  
post #7 of 12 Old 01-12-2016, 12:50 PM
Moderator
 
CheapBassTurd's Avatar
 
Join Date: May 2009
Location: Indiana/ Michigan line at the Lake
Posts: 1,585
That's what my '09 did when I had that tiny steel barrel in upside down.
(needle seat/ guide.) Sits right on the jet.

There could/ can be a few varnish blobs floating around the the system.
That stuff will clog petcock screens, block a jet or two, etc.
The Seafoam is the ticket as you already did. Might need another dose.

Also, I had to replace all of my rubber hoses due to cracking and deterioration
over the last 7 years, except the battery tube. The rubber was very soft and
began hardening after about two years.

It's obviously not all of these, but one could easily be the point of headaches.

This is my son, with whom I am well pleased." ----God
CheapBassTurd is offline  
post #8 of 12 Old 01-12-2016, 01:01 PM Thread Starter
Neutral
 
gatorrider's Avatar
 
Join Date: Dec 2015
Posts: 8
Quote:
Originally Posted by CheapBassTurd View Post
That's what my '09 did when I had that tiny steel barrel in upside down.
(needle seat/ guide.) Sits right on the jet.

There could/ can be a few varnish blobs floating around the the system.
That stuff will clog petcock screens, block a jet or two, etc.
The Seafoam is the ticket as you already did. Might need another dose.

Also, I had to replace all of my rubber hoses due to cracking and deterioration
over the last 7 years, except the battery tube. The rubber was very soft and
began hardening after about two years.

It's obviously not all of these, but one could easily be the point of headaches.
Hey thanks man, I added the Seafoam again and drove around the neighborhood and it seems to be fine today. I will take it out for a good run later and see if that problem comes up again.
gatorrider is offline  
post #9 of 12 Old 01-12-2016, 06:55 PM
1st Gear
 
ReadyToBugout's Avatar
 
Join Date: Oct 2014
Location: Idaho
Posts: 93
Garage
How long has it been sitting without running?

2014 Green/Black KLR650 "New Edition"
2006 Yamaha Cherry Red FZ1
2007 Yamaha VStar 1100 (Wifes, but I've ridden it more than her)
ReadyToBugout is offline  
post #10 of 12 Old 01-12-2016, 07:16 PM Thread Starter
Neutral
 
gatorrider's Avatar
 
Join Date: Dec 2015
Posts: 8
About five years...the guy said he would start it here and there. He kept the battery on a trickle charger for a bit. Then he just stopped messing with it. He is an MD out of Miami area. He fell off twice and gave up riding it.
gatorrider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Old Story, New Twist twinjet Never let your guard down 0 05-29-2015 07:53 AM
2004 KLR stalls when throttle at idle and quick throttle blip sixpointfive 1987 to 2007 Wrenching & Mods 4 05-17-2015 10:06 PM
My KLR stalls at high RPM topper 2008+ KLR650 Wrenching & Mod Questions 7 09-18-2014 10:36 PM
engine stalls when applying any throttle benny m 2008+ KLR650 Wrenching & Mod Questions 5 08-25-2011 03:32 AM
help! KLR stalls when leaning danny.welsch KLR & Other Motorcycle Related Discussion 8 09-30-2010 08:53 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome