After 685 / Oil Screen Question - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-03-2016, 05:39 PM Thread Starter
1st Gear
 
Join Date: Apr 2016
Location: Raleigh, NC
Posts: 21
Send a message via Skype™ to kaineb
After 685 / Oil Screen Question

Did a 685 on my new KLR right off the bat, 75 miles on the clock and i have a concern. When installing i cleaned the cylinder, i just forgot to WD40 it before firing it up. I did crank it by hand a number of times though to check for issues before starting.

I did the initial startup run without changing the original filter since it only had 75 miles on it. The kit says to run up to 20 miles and then do an oil and filter change.

When i did this i found a little bit of metal on the magnetic drain plug i put in, and then a little bit in the bottom of the oil filter housing and on the oil filter itself. I wiped it clean with a paper towel.

Is this to be expected or do we have a problem? I have done a 50 mile run since the oil change and it seems to be running fine. Again, i never checked it from the factory to see if there were any sediment in there either, but i suspect not.

Lastly, should i remove the cover and check the oil screen after all of the break-in is completed?
kaineb is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-03-2016, 06:34 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,541
kaineb,
Totally normal for a new KLR engine or any engine to have some fine crumbs in the oil filter. That is why it is there. With a spin-on oil filter, most people never see the crumbs, so they never worry about what they haven't seen.
Just be certain to keep those crumbs from flowing down the 6:00 oil hole. It goes straight to the bottom rod bearing! I use a little red battery vent nipple to temporarily plug the 6:00 hole during an oil change.

As to checking the oil pre-screen. I wouldn't waste my time or a pair of gaskets, unless I had another reason to go there!

I can give you a Very Good Reason. A KLR oil filter does NOT filter 100 % of its oil. The filter cavity needs a second 'o'-ring to keep the dirty oil from re-mixing with the just filtered oil. 1996 and newer models are worse than my 1987 in this respect.

Click on this, http://www.klrforum.com/1987-2007-wr...ya-got-42.html

Ten postings, with pics, for your viewing pleasure.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting
pdwestman is offline  
post #3 of 5 Old 04-03-2016, 06:49 PM Thread Starter
1st Gear
 
Join Date: Apr 2016
Location: Raleigh, NC
Posts: 21
Send a message via Skype™ to kaineb
Hey, thank you for that very well thought out reply. I will certainly read up. I was looking yesterday at possibly adding an Oil Pressure Gauge but it looks like the company that made them aren't doing so any more. I have seen a few people make their own but with the components in a place that can easily be caught and broken. This type connected to the upper banjo bolt, out of the way.
kaineb is offline  
 
post #4 of 5 Old 04-03-2016, 07:17 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,541
kaineb,
Did you click on the Blue Link?

Oil pressure gauge, a few more postings for your viewing pleasure,
http://www.klrforum.com/1987-2007-wr...de-data-3.html

http://www.klrforum.com/441617-post385.html

http://www.klrforum.com/433201-post349.html

One more older link, un-modified oil system,
http://www.klrforum.com/112939-post8.html

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting

Last edited by pdwestman; 04-03-2016 at 07:21 PM. Reason: added older link.
pdwestman is offline  
post #5 of 5 Old 04-03-2016, 09:46 PM Thread Starter
1st Gear
 
Join Date: Apr 2016
Location: Raleigh, NC
Posts: 21
Send a message via Skype™ to kaineb
I did see those links while i was looking for an oil gauge solution. I just want to buy something that is set up and works. Wish someone would make a kit, ha ha.
kaineb is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
685 piston question artrix 2008+ KLR650 Wrenching & Mod Questions 5 07-20-2014 11:50 AM
OIL Screen and gummy worms Grinnin 1987 to 2007 Wrenching & Mods 19 01-31-2014 09:52 PM
Another Oil Question WVBassFan 1987 to 2007 Wrenching & Mods 23 06-26-2012 08:03 AM
Cleaning the oil screen Tom Schmitz How To's & Tech Guides 12 02-26-2011 12:34 AM
KLR Oil Screen Cleaning Day klr4evr 1987 to 2007 Wrenching & Mods 4 09-29-2007 11:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome