'08 Fan Question - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 11-27-2008, 02:23 AM Thread Starter
Neutral
 
Stingray's Avatar
 
Join Date: Nov 2008
Posts: 7
Send a message via Skype™ to Stingray
'08 Fan Question

Hey guys,

Yesterday afternoon I was stuck in traffic, and my fan came on. Shortly after that I stopped in my garage, and the fan was still on. When I switched the ignition off, the fan went off. So I thought this was strange. So I switched it on again, an voila the fan went on again. Shouldn't the fan run when the bike is switched off?
Stingray is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 11-27-2008, 05:17 AM
1st Gear
 
Join Date: Apr 2007
Posts: 40
Fan

I have an 07 and that is normal. The fan comes on at about mid guage (50-60%) and then will run a short amount of time after shut off but not so much it kills your battery.

2007 KLR
2008 Concours 14

corbin seat, doohickey, agm battery, subframe bolts, progressive springs, stainless brake lines, anti vibration mirrors, wolfman expedition tank bag, panniers, electric outlet for gps, clock, moved license plate, magnetic drain plug, mefo explorer 99 tires, 320 mm Rotor with Galfer green pads front and black on rear
mwynn is offline  
post #3 of 6 Old 11-27-2008, 06:07 AM Thread Starter
Neutral
 
Stingray's Avatar
 
Join Date: Nov 2008
Posts: 7
Send a message via Skype™ to Stingray
That's the problem. Mine doesn't run at all when I switch the bike off, the fan stops. When I switch it back on, the fan starts again. Even though the gauge was 2-thirds from the bottom, it still didn't run when the bike was switched off.

On all my other bikes, when the bike is hot and you switch it off the fan still runs for a short while. On the KLR, it just stops.

I've got her booked for her first service on Thursday next week, and I asked them to look into it.
Stingray is offline  
 
post #4 of 6 Old 11-27-2008, 11:10 AM
1st Gear
 
FATTKAW's Avatar
 
Join Date: Aug 2008
Location: Romeoville Il.
Posts: 61
Send a message via MSN to FATTKAW
thats the way it's wired.
my old zx-9 would stay on when hot.
my zx-10 goes off with the key.

no real point of cooling off the radiator if the pump isn't spinning.
FATTKAW is offline  
post #5 of 6 Old 11-28-2008, 01:58 PM
1st Gear
 
Join Date: Sep 2008
Location: Texas Panhandle
Posts: 97
On the pre '08s the fan ran irregardless of key-switch position. On the '08 a larger radiator made it unnecessary for the fan to continue to run after the engine was shut off.
ScareCrow is offline  
post #6 of 6 Old 12-02-2008, 01:48 AM Thread Starter
Neutral
 
Stingray's Avatar
 
Join Date: Nov 2008
Posts: 7
Send a message via Skype™ to Stingray
Thanx guys. Now I'm not worried so much anymore
Stingray is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Members.. Ask a question.. Any question.. Paper The Off Topic Lounge 85 05-23-2012 11:43 AM
Just a question. 2006klr650 Southeast Riders 15 09-03-2008 03:04 PM
PCV mod question thumbs 1987 to 2007 Wrenching & Mods 1 08-31-2008 08:10 PM
another oil question Kawi_KLR650 2008+ KLR650 Wrenching & Mod Questions 28 07-14-2008 05:03 PM
KLX Question double a 1987 to 2007 Wrenching & Mods 2 05-28-2008 01:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome