Dumb question on Batter - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 4Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 01-30-2017, 01:50 PM Thread Starter
Neutral
 
Join Date: Jan 2017
Posts: 7
Dumb question on Batter

I was in a hurry (you know how this ends) and hooked up my new battery backwards. Corrected that mistake but now my steed is totally dead, no power anywhere. checked the main 20a fuse and it was not blown. Any suggestions?
Fbmartin is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 01-30-2017, 02:34 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,541
What year is the bike? And where exactly is that 20 amp fuse located? You might have actually checked the 'Spare Fuse' if it is a 2008 & up.

What battery Brand and number did you install?

Read more down here,
http://www.klrforum.com/1987-2007-wr...out-fuses.html

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting

Last edited by pdwestman; 01-30-2017 at 02:36 PM. Reason: link added
pdwestman is offline  
post #3 of 12 Old 01-31-2017, 02:44 PM Thread Starter
Neutral
 
Join Date: Jan 2017
Posts: 7
2012
The fuse was located at the bottom of a connection that was in front of the battery location. On the left side of bike as you face forward.
Fbmartin is offline  
 
post #4 of 12 Old 01-31-2017, 06:26 PM Thread Starter
Neutral
 
Join Date: Jan 2017
Posts: 7
Is this a relay? Located on left side of bike (2012). Battery has power. New fuse but bike is dead (no power). Could this be my culprit?
Fbmartin is offline  
post #5 of 12 Old 01-31-2017, 06:28 PM Thread Starter
Neutral
 
Join Date: Jan 2017
Posts: 7
Here are the pics
Attached Images
File Type: jpg 20170131_174348_1485908825533.jpg (514.8 KB, 15 views)
File Type: jpg 20170131_174337_1485908849800.jpg (551.4 KB, 11 views)
pdwestman likes this.
Fbmartin is offline  
post #6 of 12 Old 01-31-2017, 06:52 PM
Pretty in Pink, dunno why
 
Tom Schmitz's Avatar
 
Join Date: Feb 2009
Location: Redondo Beach
Posts: 7,572
Garage


Tom

Tom [email protected]

“She went out slowly. The way she did it hadn’t been learned at business college.” -Philip Marlowe

“'Why' and 'How' are words so important they cannot be too often used.” -Napoleon Bonaparte


Sting like a butterfly.
Tom Schmitz is online now  
post #7 of 12 Old 01-31-2017, 06:59 PM Thread Starter
Neutral
 
Join Date: Jan 2017
Posts: 7
Outstanding, thanks. I will look at this.
Fbmartin is offline  
post #8 of 12 Old 01-31-2017, 08:51 PM Thread Starter
Neutral
 
Join Date: Jan 2017
Posts: 7
You guys rock!
Bike is running. Thanks so much for the help.
Fbmartin is offline  
post #9 of 12 Old 01-31-2017, 09:10 PM
Pretty in Pink, dunno why
 
Tom Schmitz's Avatar
 
Join Date: Feb 2009
Location: Redondo Beach
Posts: 7,572
Garage
Credit to Paul! He called it.

Glad to hear you got it going.

You should check, or have checked, the charging voltage. If that's good then it's likely that no damage was done by reversing the battery.

Tom
pdwestman and roadrash83 like this.

Tom [email protected]

“She went out slowly. The way she did it hadn’t been learned at business college.” -Philip Marlowe

“'Why' and 'How' are words so important they cannot be too often used.” -Napoleon Bonaparte


Sting like a butterfly.
Tom Schmitz is online now  
post #10 of 12 Old 02-02-2017, 04:04 PM Thread Starter
Neutral
 
Join Date: Jan 2017
Posts: 7
Is this done by checking the battery with my tester? New battery and running slightly over 12v. on Trickle charger.
Fbmartin is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dumb question of the day regarding shims drtrider 2008+ KLR650 Wrenching & Mod Questions 7 04-07-2017 09:58 PM
A dumb question about the tool kit Slowpoke 2008+ KLR650 Wrenching & Mod Questions 9 05-24-2013 06:48 PM
Kind of a dumb question but curious abq sketchman Introductions 8 07-18-2012 02:54 AM
Dumb doohickey question jduff8505 1987 to 2007 Wrenching & Mods 2 06-14-2012 07:21 AM
Dumb tire sizing question 2trax4me 1987 to 2007 Wrenching & Mods 10 06-09-2012 02:34 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome