no power at switch - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-04-2017, 04:35 PM Thread Starter
Neutral
 
Join Date: Jun 2017
Posts: 1
no power at switch

Hello KLR fans, I need a little help with elec, problem. First battery is good, no blown fuses, check. took neg. lead off battery to test for short. test light on with a touch to neg. lead. Short, found short in D pin (9pin) blue and white wire. Don't see any wires touching but short somewhere. Please any Ideas where to look next. Thanks Gary
garyc987% is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-04-2017, 04:55 PM
4th Gear
 
GoMotor's Avatar
 
Join Date: May 2014
Location: Texas
Posts: 1,261
I assume your KLR is a gen1 (?) and you are referring to the 9 wire connector from the main harness to the headlight switch. If you are saying the test light comes on between the battery ground and the blue/white wire in the harness with the ignition on, that is normal. The blue/white hot from the headlight fuse to the light switch.
GoMotor is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need more POWER! NoPowerKlr 2008+ KLR650 Wrenching & Mod Questions 25 03-06-2014 10:19 PM
Power efigalaxie 2008+ KLR650 Wrenching & Mod Questions 34 06-30-2011 06:03 AM
No Power When Ignition Switch Turned On? Photon 1987 to 2007 Wrenching & Mods 6 05-12-2010 09:08 PM
no power anywhere ssknightrider 1987 to 2007 Wrenching & Mods 5 03-07-2010 09:39 AM
Saftey Switch by-pass SWITCH Daddyjoe How To's & Tech Guides 4 07-12-2007 08:07 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome