Default Electrical Problem? Tach acting funny, Neutral flickering, etc - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 5Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 07-01-2018, 09:30 PM Thread Starter
1st Gear
 
Perry's Avatar
 
Join Date: Nov 2017
Location: Clarksville, TN 37040
Posts: 31
Garage
Default Electrical Problem? Tach acting funny, Neutral flickering, etc

I think I am having an Electrical Problem due to the heat here in Tennessee (90 degrees and over)

Red Gen II, year - 2017

https://youtu.be/0meAIaeUpqw
In the video, it starts out all whacky, but after I kick it like a horse on the left side, like 'Giddy-Up!' the rpms display as normal again...

see video

1. The Tachometer is fluttering at over 7,000 rpm while engine is in Idle at maybe 1200 rpm (video)

2. Also, the Neutral Light flickers. (not observable in video but it does it)

3. In addition, I think I may be having problems at night also because my Headlights, both at Low beam and at High beams, are flickering.

4. Finally, sometimes it's not starting, but when I kick it like a horse on the left side, it starts.

I may have to tear it apart...

Anyone have any experience with this before?
Perry is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 07-01-2018, 11:43 PM
3rd Gear
 
dan filipi's Avatar
 
Join Date: Feb 2017
Location: Van Nuys Cali
Posts: 602
Garage
Check your battery cables are tight before tearing into it. Looks like possibly a loose ground.
Toney and patroy75 like this.

2016 KLR 650
2017 BMW S1000RR (traded in for
2018 Ducati V4S
1983 GL1100 Goldwing
2017 Yamaha R1
dan filipi is offline  
post #3 of 11 Old 07-02-2018, 09:00 AM
5th Gear
 
Join Date: Jan 2011
Posts: 4,183
In my experience, KLR tachometers appear VERY SENSITIVE to a solid + 12 VDC source.

Suggest you check the 12 VDC input with a voltmeter at various engine rpm, after you clean/tighten all related connections.
Toney likes this.
Damocles is offline  
 
post #4 of 11 Old 07-02-2018, 10:21 AM
3rd Gear
 
Toney's Avatar
 
Join Date: Mar 2010
Location: Oliver Springs TN
Posts: 755
It could even be a bad battery.

“Take the risk of thinking for yourself , much more happiness , truth, beauty, and wisdom will come to you that way.” Hitchens
Toney is offline  
post #5 of 11 Old 07-10-2018, 06:01 PM Thread Starter
1st Gear
 
Perry's Avatar
 
Join Date: Nov 2017
Location: Clarksville, TN 37040
Posts: 31
Garage
>took off my side panels and seat.
>started the bike up.
>observed sparks shoot outwards from the ground lead of the battery, to the left of the bike.
>ground lead quite loose.
>nut came off the bottom of the screw, so the wire was bouncing around.
>tightened it up but had trouble aligning the nut with the screw.
>Bad eyesight didn't help.
>slapped everything back together.
>runs fine again.
>drove it over 450 miles this past weekend to include through a rainstorm.
>still running good.
mfw I feel like an idiot for not checking this right away instead of riding another 1,000+ miles before turning my attention to it because I was thinking, "Oh, this will just go away."[

Sent from my SAMSUNG-SM-G900A using Tapatalk
Perry is offline  
post #6 of 11 Old 07-10-2018, 06:59 PM
5th Gear
 
Join Date: Jan 2011
Posts: 4,183
Did you overlook this post, Perry?

Quote:
Originally Posted by Damocles View Post
In my experience, KLR tachometers appear VERY SENSITIVE to a solid + 12 VDC source.

Suggest you check the 12 VDC input with a voltmeter at various engine rpm, after you clean/tighten all related connections.


Congratulations on solving your problem.

Last edited by Damocles; 07-10-2018 at 07:02 PM.
Damocles is offline  
post #7 of 11 Old 07-10-2018, 07:06 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,235
I can't hardly imagine that your bike was able to Start with the cable that loose! Even once, much less a 1000 miles worth.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 84,000+ miles & counting
pdwestman is offline  
post #8 of 11 Old 07-13-2018, 06:47 AM
1st Gear
 
KLR Kool-Aid!'s Avatar
 
Join Date: Feb 2017
Location: Denver, Colorado
Posts: 68
Great story, and it inspired me to perform a battery service (adding water, cleaning, greasing and tightening the contacts, etc.) on my bike last night!

Glad to hear it wasn't something more complicated or expensive than a loose contact.
KLR Kool-Aid! is offline  
post #9 of 11 Old 07-13-2018, 07:10 AM
2nd Gear
 
Join Date: Apr 2018
Location: South of Charlotte, NC
Posts: 341
HAHA, anytime the tach goes nuts on a bike, your battery cable is loose. Trust me on this one. I think this has happened on EVERY bike I have ever owned.
patroy75 is offline  
post #10 of 11 Old 07-13-2018, 11:02 AM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,235
Quote:
Originally Posted by patroy75 View Post
HAHA, anytime the tach goes nuts on a bike, your battery cable is loose. Trust me on this one. I think this has happened on EVERY bike I have ever owned.
I recon you are too young to have owned a bike with a mechanical cable driven tachometer.
Tom Schmitz and dan filipi like this.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 84,000+ miles & counting
pdwestman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trail tech Vapor stealth speedometer and tach KLR Thumper 2008+ KLR650 Wrenching & Mod Questions 26 01-17-2016 10:12 AM
Lights on my bike and dash are acting up Jim05 Introductions 13 07-30-2010 01:04 PM
Neutral Light Flickering! Please Help!! Poodoo 2008+ KLR650 Wrenching & Mod Questions 6 08-13-2009 02:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome