09 klr starting issue? - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-16-2018, 11:59 AM Thread Starter
Neutral
 
Join Date: Sep 2018
Posts: 1
Bike just turns for a while especially with no choke. With it on it fires up a bit quicker but still hesitates. Does anyone know what could be wrong and need replacing?
Klr4fun is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting issue. WhiteLightning 1987 to 2007 Wrenching & Mods 2 05-07-2018 04:54 PM
Starting Issue MAPEX 1987 to 2007 Wrenching & Mods 0 08-02-2017 09:09 AM
Starting issue solved? Lockjaw KLR & Other Motorcycle Related Discussion 5 06-05-2015 01:23 PM
Slightly Annoying Starting Issue planalp 2008+ KLR650 Wrenching & Mod Questions 12 09-26-2014 11:13 PM
84 klr600 starting issue bchaffin Other KLR's - 250, 600, Tengai, C Models, KLX... 11 06-11-2014 09:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome