only Runs shortly on choke - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 2Likes
  • 2 Post By hazmatter8
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 09-16-2018, 07:31 PM Thread Starter
Neutral
 
Join Date: Sep 2018
Posts: 3
only Runs shortly on choke

I have a 2017 klr650. I rode the bike last month and had no issues. ( the bike is now out of warranty) I tried to ride the bike today and it wouldn't start... After a few tries i was able to gt it to start just with the choke on. It immediately dies after I take the choke off. I followed some advice and removed the carburetor and checked all the main and pilot valves for signs of dirt or clogging. When I took the carb apart is was very clean ..just like new as the bike only has 750 miles on it. I am really frustrated ...Not sure what it could be. the bike is just like new
hazmatter8 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-17-2018, 03:36 AM
5th Gear
 
Join Date: Jan 2011
Posts: 4,183
Could be diaphragm air leak. What shape was it in (any tears or holes?) when you disassembled your carb; are you sure you got it assembled correctly (diaphragm solidly in channel around mixing chamber)?

Reckon maybe too-low float height could be a cause . . .
Damocles is offline  
post #3 of 6 Old 09-17-2018, 05:29 AM Thread Starter
Neutral
 
Join Date: Sep 2018
Posts: 3
Thanks for the reply there were no tears the carburetor was in the like brand new condition no adjustments made to the float it’s at factory setting like a said it was brand new very strange
hazmatter8 is offline  
 
post #4 of 6 Old 09-17-2018, 07:07 PM
2nd Gear
 
KLRCraig's Avatar
 
Join Date: Jul 2018
Location: Mesa, AZ, USA
Posts: 205
If you keep the Choke on, would it keep running?
I don't know what that means, but I want to ask the Q.
Also, did you blow out the carb jets et al despite the carb being niceNnewNshiney?
I've seen some BS clogs (microscopic almost) and I'm not even a Mechanic...
Is this a Calif Bike? Are all your hoses connected (esp. tank hose)?

Last edited by KLRCraig; 09-17-2018 at 07:12 PM.
KLRCraig is offline  
post #5 of 6 Old 09-18-2018, 07:11 AM Thread Starter
Neutral
 
Join Date: Sep 2018
Posts: 3
Wow it appears that there were some small narrow plastic bags wrapped around the pet cock tube’s. Evidently from sitting in the show room floor some hater put them in the tank. Really pissed me off at least I’m up and running thanks to all
DPelletier and insan3guy like this.
hazmatter8 is offline  
post #6 of 6 Old 09-18-2018, 05:07 PM
5th Gear
 
Join Date: Jan 2011
Posts: 4,183
Quote:
Originally Posted by hazmatter8 View Post
Wow it appears that there were some small narrow plastic bags wrapped around the pet cock tubeís. Evidently from sitting in the show room floor some hater put them in the tank. Really pissed me off at least Iím up and running thanks to all
In the tank, one finds the "normal" standpipe, and the reserve standpipe. Someone actually went inside the tank and occluded the flow from these with small, narrow plastic bags? Or did they just stuff plastic bags into the tank, bags whose natural unfurling occluded petcock fuel flow?
Damocles is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Runs rough/stalls when warmed up. Mugyver KLR & Other Motorcycle Related Discussion 10 02-27-2015 03:05 PM
RPM's surge, gas mileage dropped, runs hot BarryDorr 1987 to 2007 Wrenching & Mods 10 02-21-2011 09:15 AM
Sat for a few months, now runs like crap. Mike Mecredy KLR & Other Motorcycle Related Discussion 9 01-22-2011 02:08 PM
Bike Falls Over Then Runs Rough Darkside 2008+ KLR650 Wrenching & Mod Questions 10 09-20-2010 10:00 AM
Bike only runs without gas line attached edcincy 1987 to 2007 Wrenching & Mods 3 07-08-2007 11:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome