KLR 650 will not start - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old 06-27-2019, 07:39 PM Thread Starter
Neutral
 
Ranger76's Avatar
 
Join Date: Sep 2017
Location: Alabama
Posts: 11
KLR 650 will not start

Hello everyone, I have a problem which someone with more experience than I may have encountered. I have a 2008 KLR 650. 35000+ miles. The bike shut off when I made a hard left hand turn into a parking lot. Got back my garage and recreated the bike shutting off while stationary. Bike would crank when handle bars were back 'centered'. Saw a similar thread on the Forum and started trouble shooting the 'choke cable' binding the CDI. Now the bike won't start at all. I've checked wiring connections, all ok. Installed new key switch. Fuses are good. Electrics come on, horn blows, no power to the starter. Before I take the bike to the dealer, I'd like some advice....Thanks in advance and my thanks to the Forum.
Ranger76 is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 06-27-2019, 07:56 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,528
Which fuses are good? Including the 20 amp one Under the starter Solenoid, on Gen 2 units?

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting
pdwestman is offline  
post #3 of 18 Old 06-27-2019, 07:59 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,528
Kick stand down? Kill switch Off? Try it with clutch NOT squeezed, neutral, kick-stand up.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting
pdwestman is offline  
 
post #4 of 18 Old 06-27-2019, 08:13 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,528
I was just kidding about the Spare Fuse Under the starter relay. I can read that the Main fuse under the RED Connector is good, "the horn blows".

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting
pdwestman is offline  
post #5 of 18 Old 06-27-2019, 08:16 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,528
Can you hear and Feel a single 'CLICK' from the starter solenoid each time you depress the starter button or not?

One more posting and this thread may move to "RECENT Discussions" and get more input.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting
pdwestman is offline  
post #6 of 18 Old 06-27-2019, 08:21 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,528
I can't do klr650.darknet, Glenn & I don't get along. But I didn't find you over there anyways.

Too many sites and too much BS on Facebook to even attempt to look for your issue. I can see that you are still 'logged-in'. See if this wakes things up.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting
pdwestman is offline  
post #7 of 18 Old 06-27-2019, 08:51 PM Thread Starter
Neutral
 
Ranger76's Avatar
 
Join Date: Sep 2017
Location: Alabama
Posts: 11
All the fuses are good. Main fuse (20 amp) and the others (15 amp).
Ranger76 is offline  
post #8 of 18 Old 06-27-2019, 08:52 PM Thread Starter
Neutral
 
Ranger76's Avatar
 
Join Date: Sep 2017
Location: Alabama
Posts: 11
Kick Stand is up and I have inspected this 'kill switch'. All ok there. 'Kill Switch' in the handlebar is in the correct position. Neutral light is on when I turn the key.
Ranger76 is offline  
post #9 of 18 Old 06-27-2019, 08:54 PM Thread Starter
Neutral
 
Ranger76's Avatar
 
Join Date: Sep 2017
Location: Alabama
Posts: 11
No clicking at all. Press the starter button, nothing. All instrument panel lights are on and the horn blows.
Ranger76 is offline  
post #10 of 18 Old 06-27-2019, 08:54 PM Thread Starter
Neutral
 
Ranger76's Avatar
 
Join Date: Sep 2017
Location: Alabama
Posts: 11
Thanks.
Ranger76 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome