Does not respond immediately to the accelerator at highway speed - Page 3 - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 22 Old 08-12-2019, 02:31 PM Thread Starter
2nd Gear
 
Dicky's Avatar
 
Join Date: Jan 2017
Location: Panama City, Republic of Panama
Posts: 184
Good afternoon Gentlemen, yesterday I rode the motorcycle for 200 miles. This after having cleaned and oiled the air filter. I even found a small stone in the box where the foam filter goes. After cleaning I had not used the motorcycle until Sunday. Prior to having cleaned the filter I had rolled 35 miles inside the city. Fortunately, the bike worked perfectly and no longer has the delay between the throttle and the engine response. In the whole trip it never happened. I did not touch the carburetor. I only used the cleaning additive in the fuel and then cleaned and oiled the air filter.
I hope this was all.

The man on top of the mountain didnít fall there.
Dicky is offline  
Sponsored Links
Advertisement
 
post #22 of 22 Old 08-12-2019, 02:36 PM Thread Starter
2nd Gear
 
Dicky's Avatar
 
Join Date: Jan 2017
Location: Panama City, Republic of Panama
Posts: 184
Thanks again to everyone for their advice and opinions. What allowed me to have a plan A, B, C and etc. LOL

The man on top of the mountain didnít fall there.
Dicky is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome