Broken Speedo cable - Kawasaki KLR 650 Forum
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-30-2019, 07:50 PM Thread Starter
1st Gear
 
Join Date: Jul 2019
Location: Central Valley, CA
Posts: 24
Broken Speedo cable

Just got back from a short ride after putting my new front tire on the bike. About halfway through I noticed speedometer was no longer working. Pulled over and saw what i did, I did not get the hub into the groove correctly and it moved and broke the cable.
Just when I thought I was finished with everything on this bike.....time to remove the front wheel again.
Just ordered a new cable, although I have used my phone as a GPS and Speedo for several years now, so i wont miss it too much while I wait. Though there is just something not right Seeing the needle sitting on 0 all the time, it throws me off or something, I donít know.
Niteryder is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-30-2019, 08:30 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,685
I think 4200 rpm is pretty close to an actual 60 mph, on a Gen 2.

How could a miss-indexed tab on the speedo drive box cause the cable to twist off? Have you slid the inner wire out of the outer jacket to confirm a broken cable?

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting
pdwestman is online now  
post #3 of 5 Old 08-30-2019, 09:39 PM Thread Starter
1st Gear
 
Join Date: Jul 2019
Location: Central Valley, CA
Posts: 24
Here is a picture.
Attached Images
File Type: jpg DDC34D98-823E-4CB0-B958-71D3E8F6EE6E.jpg (496.5 KB, 10 views)
Niteryder is offline  
 
post #4 of 5 Old 08-30-2019, 10:16 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,685
Ooo, you Rotated the drive box well below the desired 9:00 position.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting
pdwestman is online now  
post #5 of 5 Old 08-30-2019, 10:25 PM Thread Starter
1st Gear
 
Join Date: Jul 2019
Location: Central Valley, CA
Posts: 24
Quote:
Originally Posted by pdwestman View Post
Ooo, you Rotated the drive box well below the desired 9:00 position.
Yes, thatís what happens when you donít check things before buttoning up.
Niteryder is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome