Engine troubles!! :( - Kawasaki KLR 650 Forum
How To's & Tech Guides Post your mod how to's and tech guides here. Topics will be locked only to allow editing by original author.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-13-2017, 06:41 PM Thread Starter
Neutral
 
Join Date: Jul 2017
Posts: 2
Engine troubles!! :(

Hello all!

New rider here, just got my bike 1.5 months ago. Live in Vegas and get the heck out of Vegas whenever possible on my new baby, an '09.

I took her out for an inaugural run to National Monuments and Parks over 5 days. Put 1500 miles or more, got over my fear of the highway, and started to get a taste of dirt tracks around Cedar Mesa area.

I took her out for another spin last month. About 90 miles from home I heard a big click, and my power started to decline..I thought I was running out of fuel so i turned the reserve on. By the time I was done I lost all power, rpms dropped to nothing and I pulled off the side of the interstate. I did notice the engine temp was running high that day.

Tried to start her, but got nothing. Sounded like it wanted to start, but would not turn over. Had to get towed!!!

Next day i take her to the shop,we check the oil, I was low. We figured lack of oil made her lock up. We filled the oil, and she starts right up! I take her on the highway, she feels strong as ever, I dont notice any noises. I leave counting my blessings, thinking, man, these bikes really are indestructible.

Las week I take her out for a spin. After 50 miles on the highway (70mph, 5k rpms), I notice the power starting to fade. Then no noises, but my rpms start to die so I pull off of the road, as Im coasting to a stop the rpms die. I check the oil, level is fine...kick the tires, curse a bit, then try to start her again. Wont start, then I put the choke on full and she fires up. Same thing happens one more time before I make it home.

I get in town and realize the temp guage is running a bit higher than normal, and the power is a bit weak. All the shops were closed at this hour. Next day she starts fine, power seems back to normal, but still engine temp running higher than normal.

I take her to the shop, the run every test they can think of, take her for a test drive and say nothing is wrong with her.

So...now what? Something is wrong, I now cant trust her riding anywhere but in town.

Any ideas what may be wrong?

Do I just get a mechanic to open her up and see?

Cant sell it to someone...and dealership would only give me $1000, i'd lose a lot on that deal!!

Help please!!!
KLRnewB is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-13-2017, 07:02 PM
3rd Gear
 
dan filipi's Avatar
 
Join Date: Feb 2017
Location: Van Nuys Cali
Posts: 611
Garage
There are guys here know more than me about the KLR but it sounds to me like a fuel delivery or momentary electrical problem, maybe even a combination of both. Starting from the battery, I'd test it with a full charge then work my way in checking all the connections and fuse holders. Others could advise better the fuel system.

2016 KLR 650
2017 BMW S1000RR (traded in for
2018 Ducati V4S
1983 GL1100 Goldwing
2017 Yamaha R1
dan filipi is offline  
post #3 of 3 Old 07-13-2017, 07:08 PM Thread Starter
Neutral
 
Join Date: Jul 2017
Posts: 2
I have noticed a small backfire the last few times I started her too...
KLRnewB is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubles with 2008 in Punta Arenas Kibbie KLR & Other Motorcycle Related Discussion 5 02-27-2011 08:09 PM
ENGINE NOISES SANS MOOSE ENGINE GUARD X6_Hustler 1987 to 2007 Wrenching & Mods 2 02-12-2010 01:29 AM
Engine changes basement 2008+ KLR650 Wrenching & Mod Questions 1 10-21-2009 06:33 PM
clutch troubles tcbb32 1987 to 2007 Wrenching & Mods 8 06-05-2008 07:20 AM
Noob with engine swap question....Will the KLR 650 engine fit in a KLR600? Juice_Man 1987 to 2007 Wrenching & Mods 0 04-01-2008 07:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome