New Ride - need a battery maybe? - Kawasaki KLR 650 Forum
Introductions Tell everyone a little bit about yourself.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 09-02-2015, 03:19 PM Thread Starter
1st Gear
 
Join Date: Sep 2015
Location: Yellowknife, NWT
Posts: 20
New Ride - need a battery maybe?

Hi folks. Just picked up a 2009 KLR (3,000 km) and am getting used to it. That's one heavy bike for sure. Two days ago, I was backing it up to park in my driveway after riding, and somehow managed to tip the darn thing almost to the ground....once it started falling it took all of my superhuman strength to keep it from hitting the ground and get it back upright. Anyway, the I'm assuming the battery is original, which makes it six years old and lead-acid type(?). At any rate, I went to start the bike this morning to ride to work, and the neutral light and headlamp both illuminated, but the bike wouldn't turn over at first. Just dead when I hit the start button. I got on the bike and lifted the kick-stand and tried the starter a couple more times and still nothing. I tried a few more times, and it did eventually turn over slowly for a bit and then stopped. It started fine yesterday - the motor usually turns over once or twice and then fires right up.

so, I'm thinking.....six year old battery, and possibly leaked a bit of fluid when I tipped the bike, so likely battery???? Can anyone suggest a replacement?

Thanks a bunch.........and nice meeting you!
Randinator is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 09-02-2015, 06:03 PM
OverDrive
 
Join Date: Jan 2011
Location: NW MO
Posts: 5,344
Welcome to the forum. I would recommend the Deka ETX-15L battery. Not much more than a lead-acid and no maintenance worries.



planalp is offline  
post #3 of 11 Old 09-02-2015, 07:25 PM Thread Starter
1st Gear
 
Join Date: Sep 2015
Location: Yellowknife, NWT
Posts: 20
Thanks for the reply. I just tried boosting the bike to no avail. Also tested the battery and it's showing 12.8V. Strange. When I push the starter button, either nothing at all happens, or there's a slight buzzing sound that seems to come from behind the instrument panel. The previous owner had lost the manual so I'm not sure what's back there.

Krap.
Randinator is offline  
 
post #4 of 11 Old 09-02-2015, 08:42 PM
OverDrive
 
Join Date: Jan 2011
Location: NW MO
Posts: 5,344
Well, I'm certainly no electron chaser. The symptoms in your first post led me to believe your battery is toast, especially if you're not sure how old it is.

Not sure if it's possible for a battery to be so dead it won't work for a jump/booster start but perhaps some kind of internal damage could prevent a jump start? I really don't know.

The first thing I would do is take the battery to an auto parts store, etc. for a load test.

Have you checked the battery terminals for tightness/corrosion?



planalp is offline  
post #5 of 11 Old 09-02-2015, 09:50 PM Thread Starter
1st Gear
 
Join Date: Sep 2015
Location: Yellowknife, NWT
Posts: 20
Pulled the battery and topped up the fluid in a couple cells which were pretty low but not that bad and have it on charge. It appears to be the original battery so would be six years old so will replace it anyway. Off to Crappy Tire in the pick-up.....and it's raining so i feel bad but not too bad.
Randinator is offline  
post #6 of 11 Old 09-03-2015, 11:57 PM Thread Starter
1st Gear
 
Join Date: Sep 2015
Location: Yellowknife, NWT
Posts: 20
I ended up buying a powersport "eliminator" AGM type battery and put it on charge this AM. I'd also asked my brother who builds and troubleshoots electronic circuits for a living, and also rides a bike, what he thought and he mentioned that an older bike of his did something similar and it turned out to be the starter button itself. It sits there out in the elements and the contacts in the switch get wet and corroded and eventually fail to conduct electricity. I installed the new battery and tried the starter.....nothing again but a slight buzz behind the instrument panel. I tried jiggling the starter button around a couple times as I depressed it, and eventually got the starter to engage briefly. A few more jiggles and the starter functioned normally and the bike fired up. I'll have to get at those two screws on the back of the switch assembly to access the contacts, and I'm thinking if you loosened the two nuts securing the brake/mirror/hand guard assembly, it should slide up on the handlebar away from the switch enough to give you access. Day off tomorrow, so a bit of tinkering and hopefully a simple fix with a points file and I should be go when my ride-behind shows up. Road-test next Wednesday.....
Randinator is offline  
post #7 of 11 Old 09-04-2015, 12:05 AM Thread Starter
1st Gear
 
Join Date: Sep 2015
Location: Yellowknife, NWT
Posts: 20
Oh...and I also understand you have to be careful when you open the starter switch box up as the button is spring-loaded and stuff can go flying. I'll try and google a pic of the innards to see what to expect.
Randinator is offline  
post #8 of 11 Old 09-04-2015, 07:38 AM
OverDrive
 
Join Date: Jan 2011
Location: NW MO
Posts: 5,344
See. I told you you needed a battery........ Hey, at least you've now got a maintenance-free battery and you'll always know exactly how old it is.

Hope all goes well with executing your gremlin and keep us posted on what happens.



planalp is offline  
post #9 of 11 Old 09-04-2015, 12:17 PM
4th Gear
 
GoMotor's Avatar
 
Join Date: May 2014
Location: Texas
Posts: 1,261
Here is a wiring diagram for you. I printed it on waterproof paper and always take it with me on trips. It has paid for itself twice. http://www.klr650.net/forums/attachm...3&d=1251918868

The buzzing you hear behind the dash is coming from the STARTER CIRCUIT RELAY. It is the little relay that controls the big relay called the STARTER RELAY that powers the starter and is located down between the battery and the starter behind the black plastic cover above the left foot peg. Most people would call the big STARTER RELAY a solenoid.

That buzzing should stop when you have a good connection through the start switch and its wires.

The buzzing you hear behind the dash is coming from the STARTER CIRCUIT RELAY. It is the little relay that controls the big relay called the STARTER RELAY that powers the starter and is located down between the battery and the starter behind the black plastic cover above the left foot peg. Most people would call the big STARTER RELAY a solenoid.

That buzzing should stop when you have a good connection through the start switch and its wires.
GoMotor is offline  
post #10 of 11 Old 09-05-2015, 01:39 PM Thread Starter
1st Gear
 
Join Date: Sep 2015
Location: Yellowknife, NWT
Posts: 20
Success!!! Thanks for the replies and advice. The switch comes apart fairly easily and the contacts were corroded and dirty. A few licks with the file and that did the trick. I would think this is a common problem. Good idea to service this switch, or at least carry a small file and tools to remove the switch if it fails. HINT: if you want to add another 30 minutes of anxiety to the job, be sure not to spread a drop cloth under the handle bar just in case you drop the little brass spring into the gravel under the bike when you go to reassemble.

Thanks again....Rando
Randinator is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Battery??? bkeller 1987 to 2007 Wrenching & Mods 3 06-05-2015 05:12 PM
Battery TrabFTW KLR & Other Motorcycle Related Discussion 9 09-05-2011 02:37 PM
Battery peter650 2008+ KLR650 Wrenching & Mod Questions 19 07-10-2011 01:03 AM
Need a new battery bikerbob KLR & Other Motorcycle Related Discussion 13 02-28-2011 07:24 AM
I need a battery, which one do you use? klrdan69 1987 to 2007 Wrenching & Mods 39 02-26-2010 08:48 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome