Difficult to Start; runs rough - Kawasaki KLR 650 Forum
KLR & Other Motorcycle Related Discussion Grab a seat and discuss whatever you like about the KLR or other related topics. Within reason.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 08-19-2012, 09:55 AM Thread Starter
Neutral
 
Join Date: Aug 2012
Location: Clarksville, MD
Posts: 1
Difficult to Start; runs rough

Took bike out of storage the other day. Using regular pressure of garden hose, washed the dust off. Set choke. Hit starter. Bike would run for perhaps a half second. Changed out fuel, set choke and same thing, runs for about a second.

Gave a squirt of ether into air cleaner. It started up and ran rough. Went for a 2-3 mile ride to get to operating temperature. Still running rough. After cooling off, tried to re-start. Same symptoms, will run for a second when choke is set.

Any suggestions? TIA.

Lou
'09 KLR-650 (1,400 miles)
Stiffwood1673 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-20-2012, 06:57 AM
5th Gear
 
Join Date: Sep 2006
Posts: 4,700
Chances are it's got something to do with water getting into something it shouldn't have.. Without actually being there to assist, your best bet is to start with the simple stuff and look at one thing at a time.

I'd check to make sure your plug wire is connected to the plug, that the plug is not loose in the cylinder, that the air cleaner isn't plugged, etc...

Remember, one thing at a time, or you won't know what actually fixed it (and if there's something that needs to be fixed).

My guess is the air cleaner is dirty and the extra water plugged it enough to keep it from running right, but again, it's just a guess.
Paper is offline  
post #3 of 4 Old 08-30-2012, 02:35 PM
1st Gear
 
Join Date: Sep 2011
Posts: 30
How long was it in storage?

You may need to clean the idle/pilot jet, the bowl, needle seat, and the other bits of the carb. If that isn't it, it could be a petcock / diaphragm or bad gas issue.
xuare is offline  
 
post #4 of 4 Old 08-30-2012, 03:12 PM
1st Gear
 
Ecip's Avatar
 
Join Date: Mar 2012
Posts: 91
Clean the Carb. Mbe some Carb cleaner fuel additive will do but I'd take the jets out and clean em.

Sent from my X10a
Ecip is offline  
Sponsored Links
Advertisement
 
Reply

Tags
hard to start, running rough

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Runs rough/stalls when warmed up. Mugyver KLR & Other Motorcycle Related Discussion 10 02-27-2015 03:05 PM
Rough riders Savage KLR & Other Motorcycle Related Discussion 7 04-26-2011 08:57 AM
85 kl 600 Runs crappy mapratola 1987 to 2007 Wrenching & Mods 4 02-01-2011 06:50 PM
Sat for a few months, now runs like crap. Mike Mecredy KLR & Other Motorcycle Related Discussion 9 01-22-2011 02:08 PM
Bike Falls Over Then Runs Rough Darkside 2008+ KLR650 Wrenching & Mod Questions 10 09-20-2010 10:00 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome