Jumping around 4000 RPM - Kawasaki KLR 650 Forum
KLR & Other Motorcycle Related Discussion Grab a seat and discuss whatever you like about the KLR or other related topics. Within reason.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-03-2014, 02:58 PM Thread Starter
Neutral
 
Join Date: Aug 2014
Posts: 1
Jumping around 4000 RPM

I'm newer to the forums but looking for some much needed assistance on my '01. Pretty much like clockwork at 4000 rpm my bike begins to get really jumpy. Its in every gear and only isn't there unless I accelerate through 4000 but will show up whereever I settle with the rpm's. It feels a lot like an air leak which I've been trying to find. (I tapped out the holes for the exhaust heat shield since they were stripped and welded on some bolts. It seemed to have started when I did that). I have an additional copper crush gasket for the exhaust head as well.

I've never gone through the carbs or the petcock as those could be symptoms as well. Just wanted to see if anybody has run into this as well or if it is common in the bike. I got it used with 11,000 miles.

I'm leaning towards air leak in the exhaust but idk if that could even affect the bike so much since its in the exhaust and also since it starts only at 4000 rpm. In 3rd gear the 'jumps' are pretty significant.

Any thoughts would be much appreciated!
-Rick
Rickboss is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-05-2014, 02:22 PM
Neutral
 
Join Date: Oct 2014
Posts: 1
Lean Jetting?

Sounds similar to this issue I found discussed here: bigcee.com/klr650faq.html

Lean Jetting
The KLR is jetted very lean from the factory. This can manifest itself as surging when cruising at medium throttle or 3-4,000 rpm. A quick cure is to back out the idle mixture screw a bit, and shim the stock needle up 0.020" with a washer. See the Fuel/Intake section for more info.

-John
jmoffett is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Delo 400 problem maybe Dave0430 KLR & Other Motorcycle Related Discussion 28 09-28-2013 06:34 PM
400 Miles Later, Was It A Mistake? drgibson Rider Reviews 13 10-10-2009 06:29 AM
RM 400 Watt Stator pkauf 1987 to 2007 Wrenching & Mods 0 11-27-2008 04:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome