Non flashing LED's - Kawasaki KLR 650 Forum
KLR & Other Motorcycle Related Discussion Grab a seat and discuss whatever you like about the KLR or other related topics. Within reason.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-21-2016, 04:22 PM Thread Starter
1st Gear
 
Join Date: Oct 2015
Location: Warkworth, New Zealand
Posts: 15
Send a message via Skype™ to Justin Capitao
Post Non flashing LED's

Hey guys

I have replaced all my indicators with LED indicators. I went and bought a new LED Flasher relay as per the pic, but all the indicators still just stay on. Any suggestions?
Attached Images
File Type: jpg P1000805.jpg (503.8 KB, 4 views)
File Type: jpg LED Relay.JPG (168.1 KB, 4 views)
Justin Capitao is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-21-2016, 06:36 PM
1st Gear
 
ReadyToBugout's Avatar
 
Join Date: Oct 2014
Location: Idaho
Posts: 93
Garage
Have you tried swapping the wires? Swapping them should do the trick. You only have two wires to chose from on these signals, correct?

Side note of info... DC voltage really matters in which orientation of your wire leads. Direct Current (DC) only has one path and no frequency which is opposite of Alternating Current (AC) which travels both negatively and positively and the frequency is the rate of which it travels; ie. 60 Hz (frequency), there are 60 pulses within one second.

When at home you can hook up AC either way with your wire leads and it doesn't matter due to the current traveling both positive and negative on your sine waves. On generators and rectifiers, diodes (diode packs more specifically) are used to convert AC into DC by orientation of the diodes to allow the current to travel only one way and not the other and the result is DC voltage/current.

2014 Green/Black KLR650 "New Edition"
2006 Yamaha Cherry Red FZ1
2007 Yamaha VStar 1100 (Wifes, but I've ridden it more than her)

Last edited by ReadyToBugout; 01-21-2016 at 07:00 PM.
ReadyToBugout is offline  
post #3 of 4 Old 01-21-2016, 08:48 PM Thread Starter
1st Gear
 
Join Date: Oct 2015
Location: Warkworth, New Zealand
Posts: 15
Send a message via Skype™ to Justin Capitao
When i turn the indicator selector on, all 4 indicators come on, without flashing. If i swap the wires around, then no indicators come on.
Justin Capitao is offline  
 
post #4 of 4 Old 01-21-2016, 09:16 PM
4th Gear
 
GoMotor's Avatar
 
Join Date: May 2014
Location: Texas
Posts: 1,204
The fact that there is no flashing when you have it wired right indicates that the relay is bad.

The wiring diagram at the web site for the relay shows the positive lead (Brown Wire) goes to the X terminal #49 on the relay and the power out (Orange Wire) goes to the L terminal #49a.

If you have it wired that way and it doesn't work, the relay is most likely defective.

Both sides light up because the dash indicator bulb cross feeds between the right and left sides so the single indicator bulb can work for both sides. In stock form the indicator bulb is so small compared to the signals that it does not cross feed enough current to light the opposite side, but with LED signals the incandescent dash bulb cross feeds enough current to light them.

From Tom Schmitz's comments it appears that the small #194 LED dash bulb he is using cross feeds so little current that the opposite side don't light up. That LED #196 indicator bulb is and has to be non-polarized so that it can cross feed to both sides or he has wired in some diodes to solve the problem.

Last edited by GoMotor; 01-21-2016 at 09:20 PM.
GoMotor is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
LED Headlights? Maverik 1987 to 2007 Wrenching & Mods 6 07-22-2014 12:14 AM
Led's? Better? pokyIDAHO6ft4 1987 to 2007 Wrenching & Mods 12 04-14-2014 08:37 PM
2008 total LED Upgrade - Needed diodes built into some LED panel lamps Adventure-Moto 2008+ KLR650 Wrenching & Mod Questions 21 02-02-2013 07:55 AM
LED Question... cvo 2008+ KLR650 Wrenching & Mod Questions 3 05-07-2012 09:39 AM
An easy fix for signal "fast" flashing w/ aftermarket blinkers MeefZah 1987 to 2007 Wrenching & Mods 2 05-05-2007 09:08 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome