water causing the bike to die - Kawasaki KLR 650 Forum
KLR & Other Motorcycle Related Discussion Grab a seat and discuss whatever you like about the KLR or other related topics. Within reason.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-17-2016, 03:56 PM Thread Starter
1st Gear
 
bakada's Avatar
 
Join Date: Dec 2007
Location: North Pole, AK.
Posts: 82
water causing the bike to die

So after 3 years the stars aligned and my buddy and I finally made the run from Fairbanks up the Dalton Highway to Deadhorse and Prudhoe Bay last weekend. Weather was great. They did have a winter storm warning for Atigan pass the morning we left but the forecast was for highs in the 60s the next day which was when we were planning to cross. We made the 270 mile run to Coldfoot on Friday and spent the night there on the grass listening to trucks idle and come and go. Saturday we headed out of Coldfoot for the 240 mile run to Deadhorse. The road over Atigun Pass was great and the only remnants of the 4 inches of snow from the previous day was off the side of the road. About 90 miles out of Dead horse we encountered our first mud thanks to the state and there damn water trucks. About 2 miles into a 5 mile section of watered mucky sloppy road section my 05 KLR started to pop and buck and backfire and then died. Luckily I was at the top of a hill and rolled the half mile to the bottom. Hit the starter and it fired up and I headed off. 1/2 mile later same thing, bucking popping, backfire and dead. Again had a hill to roll down and thankfully at the bottom the state had forgone the water. I checked gas and sparkplug cap and looked at any wiring I could see but I basically had no idea. This took me about 10 minutes to do and I hit the starter and it fired up purring like a kitten. Rode the rest of the way into deadhorse without an issue. Left Deadhorse Sunday morning hoping to make the entire 530 mile run home in one day. We made it out of Deadhorse and through the construction zone before the state had a chance to water the road again and made good time. We ate lunch in Coldfoot at 2:00pm and headed out. About 8:30 pm and 27 miles from home it started to rain. I ended up behind a semi heading down hill into Fairbanks and really was getting soaked from his spray when the bike started popping and bucking and backfiring again and then it died. I was at speed so I headed for the shoulder but left it in gear rolling down the hill. It would pop and run and then backfire and die and then run again. After about 3/4 of a mile of this it started running and home I went. By the time it started running again I was well behind the truck and out of the heavy spray. It rained on me the rest of the way home but nothing like I was getting behind the truck and it ran great with no issues. The next day I washed all the muck off the bike and decided to let the bike idle while I washed it and sure enough any time I got water up under the head light it died. It only took a few minutes and it started and ran fine. Anyone have any idea what is up under the headlight/speedometer cluster that is getting wet and shorting but only takes a minute or two to drain off and then work normally? I have looked and poked around but I cant tell what it would be. Thanks for any and all help.

2005 Red one
bakada is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-17-2016, 04:18 PM
4th Gear
 
Join Date: Aug 2010
Location: Kelowna, B.C.
Posts: 2,236
google "KLR T mod"


Dave
DPelletier is online now  
post #3 of 4 Old 06-17-2016, 04:21 PM
4th Gear
 
Join Date: Aug 2010
Location: Kelowna, B.C.
Posts: 2,236
To get you started;

KLR650 FAQ

MarkNet - KLR650

it certainly COULD be electrical, but this is a common issue.

Dave
DPelletier is online now  
 
post #4 of 4 Old 06-17-2016, 05:40 PM Thread Starter
1st Gear
 
bakada's Avatar
 
Join Date: Dec 2007
Location: North Pole, AK.
Posts: 82
Sorry I guess I should have mentioned it but I have done the T mod and also both the clutch and Kickstand mods. This appears to be electrical and seems to happen when I get water up under or around the headlight, key and speedo.

2005 Red one
bakada is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
19 fire fighters die, all Prescott Hot Shots CraigES The Off Topic Lounge 16 07-26-2013 09:43 PM
Heated handgrips causing lights to dim. redbandit05 1987 to 2007 Wrenching & Mods 14 02-15-2013 08:27 PM
09 water worthy Glasser KLR & Other Motorcycle Related Discussion 1 05-01-2011 08:55 PM
Water in oil? pinoyal 1987 to 2007 Wrenching & Mods 9 02-07-2009 04:52 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome