Engine Knocking - Kawasaki KLR 650 Forum
KLR & Other Motorcycle Related Discussion Grab a seat and discuss whatever you like about the KLR or other related topics. Within reason.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-11-2009, 03:54 PM Thread Starter
Neutral
 
Join Date: Apr 2009
Posts: 2
Engine Knocking

My "99 KLR has a knock coming from the engine when I lug it or let the clutch out with the brake on. I am using premium gas so I doubt if it is pre-ignition. It's not like a heavy metallic knock like a car engine with a rod bearing gone .. but a sharper pinging sound. There is no noise at idle and is not noticable when riding with a full face helmet. It doesn't sound like it's going to blow up or anything but is definitely a concern .. Any ideas ????? ... Rod
rodthewrecker is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-11-2009, 06:14 PM
2nd Gear
 
maprimm's Avatar
 
Join Date: Jun 2008
Location: Stockton Mo
Posts: 368
You could change oil check for shiny stuff.

up grade's 2008 green,
Cee Baily tinted wind shield, studibaker skid plate, one inch length added to shifter, highway pegs, steel pegs,Jardine pipe, trunk, head light rock gard, , 12 volt power outlet, 16 tooth front sprocket, Progressive front springs, studibaker master cylender guard, PVC mod,Doo Hickey, one wheel offroad trailer, night vision ammo cans for side bags my oun tank gards.

http://i358.photobucket.com/albums/o...-59-44_731.jpg
maprimm is offline  
post #3 of 4 Old 04-16-2009, 10:58 PM
Neutral
 
Join Date: Mar 2009
Location: Las Vegas
Posts: 4
How many miles?
Mine does the same thing. I THINK its because they are jetted a little lean, anyway if your motor doesn't have an obvious knock at idle don't worry about it.

Change oil as suggested and if you see anything other than tiny glitter you have a problem, but mine makes same sound and its just because you are lugging it a bit.
Roady is offline  
 
post #4 of 4 Old 04-16-2009, 11:21 PM Thread Starter
Neutral
 
Join Date: Apr 2009
Posts: 2
Thanks for the advise .. as it turns out I talked to the dealer about it yesterday and he said the same thing. He said after a few miles they get a bit of carbon build up and tend to ping a bit ...said to turn the screw at the front of the carb 1/2 a turn and it should go away ... Rod
rodthewrecker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
What engine oil are u using? Gitrdun 1987 to 2007 Wrenching & Mods 32 09-18-2016 11:23 PM
KLR 650 Knocking at Idle to 3100 rpm deacon 1987 to 2007 Wrenching & Mods 14 10-19-2014 02:06 PM
ENGINE NOISES SANS MOOSE ENGINE GUARD X6_Hustler 1987 to 2007 Wrenching & Mods 2 02-12-2010 01:29 AM
Noob with engine swap question....Will the KLR 650 engine fit in a KLR600? Juice_Man 1987 to 2007 Wrenching & Mods 0 04-01-2008 07:00 PM
engine oil derek 1987 to 2007 Wrenching & Mods 1 08-21-2007 04:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome