Running rough - Kawasaki KLR 650 Forum
KLR & Other Motorcycle Related Discussion Grab a seat and discuss whatever you like about the KLR or other related topics. Within reason.

 1Likes
  • 1 Post By pdwestman
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-25-2020, 12:51 AM Thread Starter
Neutral
 
Join Date: Apr 2020
Posts: 2
Running rough

First ride today on my 2010!! Awesome..but after I ripped through some large mud and water holes the bike stalled...started and stalled several times.. .ran rough for a few minutes so I let it idle and then off we went...what could have gone wrong?
Kim D Jones is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-25-2020, 11:24 AM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 6,490
Maybe a loose spark plug cap allowed water to ground out ignition & engine heat dried out the water?

Maybe the underside of your air filter box is Melted Open from exhaust gasket failure & it sucked water into carb & has been breathing unfiltered/dusty air?
Toney likes this.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting
pdwestman is offline  
post #3 of 4 Old 04-25-2020, 09:54 PM Thread Starter
Neutral
 
Join Date: Apr 2020
Posts: 2
Ok thanks a lot..I will check it out
Kim D Jones is offline  
 
post #4 of 4 Old 04-27-2020, 05:36 PM
2nd Gear
 
Join Date: Apr 2019
Location: Minnesota
Posts: 134
Garage
Kim, welcome to the forum. This is a great place with beaucoup knowledge and great people.
Uncle Dick is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome