Has the oil comsumption problem been resolved? - Kawasaki KLR 650 Forum
KLR & Other Motorcycle Related Discussion Grab a seat and discuss whatever you like about the KLR or other related topics. Within reason.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-20-2009, 03:39 PM Thread Starter
Neutral
 
Join Date: Dec 2006
Posts: 6
Has the oil comsumption problem been resolved?

Sorry if this subject has been beaten to death, but I'd like to know if Kawasaki has resolved the oil comsumption problem on the '09-10 KLRs...if so, how did they do it?

Thanks for all responses...

Bob
gumshoe4 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-21-2009, 09:24 PM
1st Gear
 
Extrooper's Avatar
 
Join Date: Nov 2009
Posts: 68
Smile

Bob, I can't speak for everyone but I have two 09 models and neither appear to have an oil consumption problem. I purchased both last March and my wife and I have almost 2,300 miles on each. I have been riding for the last 35yrs on the street and these are the first dual sport bikes I have owned. We are very pleased with the bikes and they are perfect for our type of riding. We don't do any hardcore dirt riding but we are now able to go places I would not have taken our large touring bike. I have heard that Kawasaki experimented with a different type of piston ring on the 08 models but switched back when they ran into oil consumption problems. I don't know if that is true but it seems reasonable. The 09's don't seem to have the problem and not all 08's had the problem either. Hope that helps.

Greg

Last edited by Extrooper; 11-21-2009 at 09:25 PM. Reason: spelling
Extrooper is offline  
post #3 of 4 Old 11-23-2009, 12:09 AM Thread Starter
Neutral
 
Join Date: Dec 2006
Posts: 6
Yes, that's reassuring. I'm interested in the KLR, but would not buy one if it was going to use oil like a 2-stroke...I know they're bikes built to a price point, but I think they should still not be doing that...

Thanks, Greg!
gumshoe4 is offline  
 
post #4 of 4 Old 11-23-2009, 04:33 PM
4th Gear
 
SLO-KLR's Avatar
 
Join Date: Sep 2006
Location: Paso Robles, CA.
Posts: 1,333
I have seen a few reports of 09's burning oil but nothing like the 08's.
SLO-KLR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd Problem with 2 up sm0kediver 1987 to 2007 Wrenching & Mods 3 10-02-2008 09:15 PM
Transmission Problem? Markk9 2008+ KLR650 Wrenching & Mod Questions 9 07-25-2008 05:32 AM
Fuel problem JesseA 1987 to 2007 Wrenching & Mods 12 07-23-2008 09:57 AM
Speedometer Problem dugklr 1987 to 2007 Wrenching & Mods 4 07-06-2008 10:25 AM
Anyone ever have this problem? changvoll 1987 to 2007 Wrenching & Mods 4 06-10-2007 01:05 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome