help! KLR stalls when leaning - Kawasaki KLR 650 Forum
KLR & Other Motorcycle Related Discussion Grab a seat and discuss whatever you like about the KLR or other related topics. Within reason.

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 09-28-2010, 10:10 PM Thread Starter
Neutral
 
Join Date: Sep 2010
Posts: 2
help! KLR stalls when leaning

I've got 2008 klr 650 that has developed an odd problem. Whenever it is leaning to the left, like on the kickstand, it idles horribly and is next to impossible to start. Straighten it up, and it idles and runs fine. Lean it over again, and it stalls. Leaning to the right has no effect - only leaning to the left

Any ideas? I'm stumped. Thanks.
danny.welsch is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 09-28-2010, 11:09 PM
4th Gear
 
SLO-KLR's Avatar
 
Join Date: Sep 2006
Location: Paso Robles, CA.
Posts: 1,333
Your choke cable is caught up on something so that every time you turn the bars to the left it applys the choke. Check the routing carefully.
SLO-KLR is offline  
post #3 of 9 Old 09-30-2010, 07:41 AM Thread Starter
Neutral
 
Join Date: Sep 2010
Posts: 2
Slo-KLR, I wish it was that simple, but it still happens even when the bars don't move. And, a new development that I noticed yesterday - if while riding, I smack the tank with my right knee, I can make it skip. Smack the tank with my left knee, and nothing happens. Thoughts?
danny.welsch is offline  
 
post #4 of 9 Old 09-30-2010, 09:07 AM
4th Gear
 
Spec's Avatar
 
Join Date: Apr 2010
Location: Gateway to Death Valley!
Posts: 1,928
Quote:
Originally Posted by danny.welsch View Post
Slo-KLR, I wish it was that simple, but it still happens even when the bars don't move. And, a new development that I noticed yesterday - if while riding, I smack the tank with my right knee, I can make it skip. Smack the tank with my left knee, and nothing happens. Thoughts?


Maybe there's a short in the harness when the tank is leaning (or being smacked!) towards the left. Check right where the harness comes off the battery and goes under the tank, there's an edge right there that could cut into it. Another likely spot is where the harness passes over the voltage regulator. There may or may not be an obvious burn mark but if it looks pinched...

Check the entire harness, there was a recall on it.

No eye has seen, no ear has heard, no mind has conceived what God has prepared for those who love him. 1 Cor 2:9
Spec is offline  
post #5 of 9 Old 09-30-2010, 01:25 PM
Moderator
 
klr4evr's Avatar
 
Join Date: Mar 2007
Location: Fort Sask , Alberta, Canada
Posts: 3,486
Garage
Send a message via Skype™ to klr4evr
Sounds like one of those right turn only bikes.

My Kaw Barn - 2004 KLR, 2006 Concours (sold), 1997 Bayou 400.

"It's a friggen motorcycle, it's not supposed to be comfortable, quiet or safe. The wind noise is supposed to hurt your ears, the seat should be hard and riding it should make you shit your pants every now and then. "

<--- Please fill in the 'Location' on your personal profile page. User CP/Edit Your Details

This information makes it much easier for other members to answer/comment on your posts.
klr4evr is offline  
post #6 of 9 Old 09-30-2010, 01:29 PM
Threadjacker
 
Lockjaw's Avatar
 
Join Date: Jul 2008
Location: Benicia, CA
Posts: 6,750
Quote:
Originally Posted by klr4evr View Post
Sounds like one of those right turn only bikes.
Your bike isn't by any chance painted brown with the letters UPS on it is it?




"In a car you're always in a compartment, and because you're used to it you don't realize that through that car window everything you see is just more TV." R. Pirsig

PPMC #1.
Soon, we ride.

AKA JD Mader or you can call me "Dan" just not early for dinner.

Click my handle for a link to my homepage/blog...which has nothing to do with MCs. Free literature and music! Viva La Revolucion!
-------------------
2008 KLR 650
RIP DM - Soon, we ride.
Lockjaw is offline  
post #7 of 9 Old 09-30-2010, 06:25 PM
4th Gear
 
SLO-KLR's Avatar
 
Join Date: Sep 2006
Location: Paso Robles, CA.
Posts: 1,333
Quote:
Originally Posted by Spec View Post
Maybe there's a short in the harness when the tank is leaning (or being smacked!) towards the left. Check right where the harness comes off the battery and goes under the tank, there's an edge right there that could cut into it. Another likely spot is where the harness passes over the voltage regulator. There may or may not be an obvious burn mark but if it looks pinched...

Check the entire harness, there was a recall on it.
Definately check the wiring harness.
SLO-KLR is offline  
post #8 of 9 Old 09-30-2010, 06:59 PM
1st Gear
 
trailrider's Avatar
 
Join Date: Sep 2010
Location: Kalifornia
Posts: 47
Talking Kawasaki Wiring Recall

There was a factory recall for the '08 KLR650 for a potential wire shorting out under the fuel tank. The wire was placed in such a way during manufacturing that the wire insulation could/would wear through during the operation of the bike. Call Kawasaki in California and give them your VIN number and they can tell you if your bike has been recalled and corrected.
Or, simply remove your fuel tank and check out the wiring under the tank.
Good luck!

"Just Happy to be Here"
trailrider is offline  
post #9 of 9 Old 09-30-2010, 08:53 PM
1st Gear
 
Join Date: Sep 2008
Location: Texas Panhandle
Posts: 97
Sounds like you have a loose connection on the brown wire OR ground wire. Since you have not blown a fuse a short is not likely to be the problem.

Note this: The E model KLR ('08s and beyond) use a digital igniter. If the voltage is not above approximately 7 to 8 volts the bike will drop into a loping almost barely running idle like you described and will take little or no throttle. This is why it is almost impossible to push start an E model with a dead battery. Take care of your battery.

If you are electrically inclined here is a revised '08 schematic that is much easier to read than the factory schematic. The brown (BR) wire is the main power wire on the '08. The gray blocks are the igniter. It was broken into 8 pieces so no wires would cross in the schematic. This schematic shows multiple grounds but that is for clarity, they are all the same black/yellow wire that runs throughout the the bike and is tied to the battery, frame and engine.

ScareCrow is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Runs rough/stalls when warmed up. Mugyver KLR & Other Motorcycle Related Discussion 10 02-27-2015 03:05 PM
Engine stalls after it warms up, HELP. jyaremko 2008+ KLR650 Wrenching & Mod Questions 4 08-23-2010 11:43 PM
Engine stalls when i'm off then back on the gas. jyaremko 2008+ KLR650 Wrenching & Mod Questions 1 08-22-2010 03:40 PM
help! bike stalls out after a few minutes of running! snuffy 1987 to 2007 Wrenching & Mods 16 05-03-2010 05:13 PM
Stalls when put into gear Zonadoro 1987 to 2007 Wrenching & Mods 4 06-03-2008 02:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome