Kawasaki KLR 650 Forum - Reply to Topic
2008+ KLR650 Wrenching & Mod Questions For repair, maintaining or modifying discussions related to the newly updated 2008 and beyond, Generation 2 KLR650 Motorcycle.

Thread: Happy Trails bars and guard combo was not a simple bolt on ! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
11-25-2012 09:12 PM
vanslam Ill have to get a set myself.
11-05-2012 09:35 AM
wayne_l quick update , mine didnt last long , i went out for quick trip this weekend and while i parked to take some pictures the kickstand failed again and fell over crushing clutch lever and moose guard onto lever first fall .. the clearences were already too tight so it had no place to give ..
also thier large guards barlley covered my hands even with heated grips felt cold at times in the hills .
with some trail side bending i was able to finish the great ride but moose guards do not fit my klr !!

anyone find any nice aftermarket levers ?

this week real barkbusters are on order .
10-26-2012 09:45 AM
wayne_l when i went to get reciept to give you parts number i found i was a dumb ass and it was happy trails bar kit not yours and i Apologize .

same time i ordered the new bar kit i also ordered your fuze block . Wich is awsome product by the way . and i got 2 confused

sorry once again ..

wayne
10-23-2012 08:16 AM
twistedthrottle
Quote:
Originally Posted by wayne_l View Post
8 hours later and another 35 bucks in stainless screws and spacers i finally got damn guards to fit around controls and switches .. still aint right but it works for now ..

i took em on off 50 times today trying to find the right combo to clear levers and cables ony to interfere with cross brace on bars .

ii ended up having to use spacers and longer bolts on bracket to clear master cyl and clutch adjuster ..

still dont really clear very well but i can ride it now ..
bars are nice stout protapers but the moose racing large guards and brackets suck ass for street bike klr ..

i also ended up braking the guide on choke cable trying to swing guard up as i was tighning the brackets
Hi Wayne. Are you referring to the Barkbuster brand handlebars and Barkbuster brand handguards? Please tell me exactly what you ordered from us. I'd like to see if there is something wrong with the kit so we can help others avoid this level of frustration.

Kevin from Twisted Throttle
10-21-2012 07:38 PM
planalp
Quote:
Originally Posted by biglar View Post
I'm sorry for all this foofahrah, but now the link should work:

http://s1263.beta.photobucket.com/us...03788.jpg.html
Hey, I was able to see them. Thanks for posting the photo. Those look like maybe something I could work with. I appreciate it.



10-21-2012 07:18 PM
biglar I'm sorry for all this foofahrah, but now the link should work:

10-21-2012 07:16 PM
biglar It's really giving me a hard time with that 15 posts thing. Let's see if this gives me 15.
10-21-2012 07:11 PM
biglar Hmmm........let's run up a couple more posts here and see if we can beat this.

I looked on google for Tusk off-road hand protectors and it came up with several dealers and pictures. Might be an easier way to go.
10-21-2012 07:09 PM
biglar Well, I finally got it worked out and it won't let me post the URL to the picture cause I haven't posted to the forum 15 times.....and I think this is post 13.
10-21-2012 06:49 PM
biglar Planalp, I'm working on it but don't get the "Share" under the photo. Tried it in Library and same thing. I did get a line under "Image Links" that gives a line titled "EM and IM, but when I click on it it just copies to somewhere. On the welcome page is a line saying, "Share with Friends," but it leads nowhere.

Maybe we're using different versions ??
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome