Kawasaki KLR 650 Forum - Reply to Topic
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

Thread: Won't run at all off choke Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
11-12-2008 06:53 AM
DXKLR Another satisfied customer. Glad that helped. Keep a couple ounces of seafoam or Berryman's in that tank each month. Should not have any more problems.
11-12-2008 01:40 AM
graydude
All better now

Low speed jet cleaned out and a couple of #4 washers thrown on the needle and she runs like a scalded dog.
11-09-2008 05:44 PM
BIGIRON Classic low speed jet junk.
11-09-2008 05:09 PM
graydude
Won't run at all off choke

I'm stumped. I've read with great interest all the threads regarding this issue. What makes my problem a little different is the bike will only run with full choke. Any opening of the throttle no matter how small will cause the bike to die. I've checked the easy things first. No intake leaks, hoses are all clear, changed gas tanks and put one on with known good petcock and gas. Bike ran fine when put away about 5 months ago. I don't know how I can utilize the benefits of Seafoam when I can't even crack the throttle without the bike dying. Idle mixture screw is still stock as it has the EPA plud still in. Should I suspect gunk in the idle fuel circuit or try to find a source for an intake leak?

Thanks in advance for any help.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome