Kawasaki KLR 650 Forum - Reply to Topic
1987 to 2007 Wrenching & Mods For maintaining, repair or modifications of Generation 1 KLR's. 2007 and earlier.

Thread: Tachometer help Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-10-2010 04:39 PM
SAR Medic I'll give it a go....

Thanks
07-10-2010 12:09 PM
vatrader I'd be checking ground wire connections, battery first. I swapped in a new battery on a Ninja yesterday. An unintended benefit was that the tach started working again on start up.



Here's looking at the back side of your instrument cluster. Under the thumb there on the left are three screw head terminal connections. Those connections can corrode, break, etc. Pay close attention to the black / yellow connection. If those check out OK, I would look at where these lines feed into...the CDI.

Heres a WIRING DIAGRAM to chase the wiring to the CDI. Place your cursor on the schematic and click to enlarge.
07-10-2010 10:58 AM
SAR Medic
Tachometer help

I have an 07' Black and Silver ( my work horse). When out for a ride yesterday my tach. stopped working. When I turned onto a dirt rode the needle was bouncing. I am assuming the sensor worked loose.

Can anyone tell me where I may find the Tachometer sensor or have any ideas on where to check for a tach. malfunction.

My repair manual has nothing on Tach. troubleshooting.

Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome